[maemo-community] [maemo-community] URGENT! Updating the info for flashing

From: Aniello Del Sorbo anidel at gmail.com
Date: Thu Nov 19 13:19:04 EET 2009
2009/11/18  <ext-mox.soini at nokia.com>:
> 2009/11/16 Quim Gil <quim.gil at nokia.com>
>>I'm not even a Windows/Mac user so (as shameful as it is) I reckon
>>having no clue now about how these users are supposed to flash their
>>devices. Can I beg some (urgent) help from the Nokians and community
>>writers related to the pages linked above? It will save us many
>>questions in lists and forums.
> As a very much multi-platform user, I can verify that the command-line flasher-3.5 works on Windows and Mac exactly like it does on Linux. So no differences there.
> I haven't tried using the Mac GUI (770Flasher), but I'd recommend against using it, especially for the Maemo Summit participants, who are expected to flash not just the firmware binary file, but also the additional and separate eMMC binary file.
> Quick guide is:
> Linux/Mac:
> sudo ./flasher-3.5 -f -F firmware_image.bin
> sudo ./flasher-3.5 -f -F -R emmc_image.bin
> (the order is important)
> Windows:
> flasher-3.5.exe -f -F firmware_image.bin
> flasher-3.5.exe -f -F -R emmc_image.bin
> (the order is important)
> Notes:
> 1) make sure the device is turned off before starting
> 2) run the flasher command (as above) first, it will start and wait for USB connection
> 3) plug in the USB cable to the device and the computer
> 4) the flashing process should start automatically
> 5) on some computers the device never goes automatically to "firmware update" mode when USB is plugged in and flasher is running.
> 6) If you are having problems with (5), then you need to force the firmware update mode by doing (1), (2), and before (3) press and hold "u" key in the device HW keyboard, then do (3).
> ...
> The (6) is also in the flasher-3.5 documentation.
> BR,
>      Mox


I tried to flash my device to 42-11 from 41-10 a few days ago and I
followed these very steps.
It flashed the firmware (note: no -R option passed here to flasher),
but when I ran the second
flasher for the eMMC image it didn't work.
It stated something like device busy.

What one should do in these cases?

More information about the maemo-community mailing list