[maemo-developers] WPA? Re: WLAN connectivity using only wireless-tools

From: Kalle Valo Kalle.Valo at nokia.com
Date: Tue Nov 6 08:50:49 EET 2007
"ext Frantisek Dufka" <dufkaf at seznam.cz> writes:

> Kalle Valo wrote:
>>> I don't see any PSM lines for example, while with the ITOS I do.
>> Yeah, you have to enable PSM with the power iwconfig parameter.
>> Otherwise PSM is disabled.
> Interestingly this parameter need values less than 1 for sensible
> timeout, something like "iwconfig wlan0 power timeout 0.0002" gives me
> 200ms

That's weird. I'll take a look at it.

> Yesterday I tried to bring up wireless via wireless-tools too but it
> looks like it doesn't support WPA-PSK at all. It this correct?


> How the system does it anyway?

In 770/N800/N810 we do it with combination of wlancond (from
osso-wlan, GPL) and eapd (from osso-wlan-security, proprietary). 

> Then I tried to compile latest (v0.5.8) wpa_supplicant with just


> it prints two pages of scanning output but then segfaults and causes
> kernel to crash inside wlan driver.

unfortunately the Wireless Extension support in cx3110x does not yet
support wpa_supplicant. But the driver shouldn't crash anyway.

> Is there any way how to make WPA running from command line?

There's no easy solution.

> I was actually trying to do it early on boot from initfs
> as per comment #7, http://bugs.maemo.org/show_bug.cgi?id=2006
> so I have whole memory free. Looks like I really need to downgrade
> security on my router to attach to it from command line?

I'm afraid so.

Kalle Valo

More information about the maemo-developers mailing list