[maemo-developers] Gstreamer dsppcmsrc error

From: swelten at ee.ethz.ch swelten at ee.ethz.ch
Date: Wed Nov 7 14:02:58 EET 2007

I'm developing an application which takes the microphone data as input 
to determine where the user is located at the moment. Recognition is 
working fine but I got problems with the audio input. Gstreamer gives 
an error message telling "Could not open resource for reading and 
writing." and reboots the nokia. This happens after an arbritary number 
of recordings have worked well. Sometimes the nokia reboots only after 
3 recorded samples(each sample 2 seconds long), other times it works 80 

What I already tried:
- use different files as sinks every time I record a sample
- build a new pipeline and remove the old one for every recording
- vary the time between to samples are taken

This problem was already described in an earlier mailing list entry 
with the title "Gstreamer audio unstable on the 770" (Mon Sep 25 
23:46:03 EEST 2006) but there was no answer.

I hope somebody could give me a hint if this could be a problem of 
gstreamer itself or my handling of it. It would also be useful to know 
another way to record microphone input.


More information about the maemo-developers mailing list