[maemo-developers] Data corruption on N770 in OS2007 HE

From: Siarhei Siamashka siarhei.siamashka at gmail.com
Date: Sat Nov 10 09:09:41 EET 2007
On 9 November 2007, Alex DAMIAN wrote:
> the modified cx3110x driver works ok. I think it's a bit weird that my
> WRT router would assign different IP addresses depending on the driver
> loaded, but it's not an inconvenience after all.
> However I run into a bit of trouble trying to modify the initfs. I
> took out the initfs from the second HE FIASCO image, and mounted it
> with loop/block2mtd and copied all the files off it (including the
> /dev/). This pose no problem. I replaced the cx3110x.ko file, and
> tried to make the updated jffs2 image with mkfs.jffs2 (I followed your
> initfs-flasher script).
> However the jffs2 image I'm building is quite different (quite a bit
> smaller), mounting it gives signifiant differences in files compared
> to the original one, and dumping it with jffs2dump shows lots of CRC
> errors.
> I even rebuild the mtd-utils from CVS, thinking that my Fedora has
> some bugged version, but the result is the same.
> Any idea about what I'm doing wrong ?

Make sure that you use correct jffs2 eraseblock size (both when mounting 
image and for mkfs.jffs2), it is 128KiB for Nokia 770.

More information about the maemo-developers mailing list