[maemo-developers] Trouble with gtkextra

From: Julius Luukko julle.luukko at quicknet.inet.fi
Date: Sun Nov 18 17:22:14 EET 2007
Julius Luukko wrote:
> Julius Luukko wrote:
>> [sbox-SDK_ARMEL: ~/testgtkplot] > run-standalone.sh ./testgtkplot
>> /home/julle/.osso/current-gtk-key-theme:1: Unable to find include file: 
>> "keybindings.rc"
>> testgtkplot[4227]: GLIB WARNING ** Pango - Cannot open font file for 
>> font Bitstream Vera Sans 2097151.9990234375
>> testgtkplot[4227]: GLIB WARNING ** Pango - Cannot open fallback font, 
>> nothing to do
>> It compiles and runs fine with plain GTK (just define PLAINGTK in 
>> compilation) but fails with the above error messages in scratchbox 
>> (haven't tried it in the IT)
> Replying to myself: I tried with the i386 target inside scratchbox and 
> the program runs, but without printing any text to the plot. I should 
> have remembered that the qemu emulation is not perfect. I am compiling 
> for bora.

Continuing my monologue: I took the time to install Chinook today and 
gtkextra seems to work fine. My test program


runs inside scratchbox both with X86 and ARMEL targets.

I checked the pango source code and found the above error messages in 
pangoxft_font.c in functions xft_font_get_font and load_fallback_font. 
The latter is only called from the former, but the former is called from 
several other functions in pangoxft_font.c. I took a strace in the N800 
running OS2007, but I am not sure if I have the time and knowledge to 
debug this further, or even file a bug report with this little 
information. The strace is available in




More information about the maemo-developers mailing list