[maemo-developers] Generated .deb package doesn't contain the executable file (was SPIM ported to Chinook)

From: Andrea Grandi a.grandi at gmail.com
Date: Mon Nov 19 21:22:21 EET 2007

> In the debian/rules of Debian distro for spim, the install order is
> 'dh_install' instead of '$(MAKE) DESTDIR=$(CURDIR)/debian/spim install'
> in your debian/rules file. That could be the problem. I suppose
> changing only it should give you the same problem, I do not know.

yes I tried to change it but I still get the same problem. I get this
problem even if I try to build a Spim package for my Ubuntu machine.

> Another thing that I have noticed is that if debian/compat is 4,
> DESTDIR it would be like yours 'DESTDIR=$(CURDIR)/debian/spim',
> but if there isn't debian/compat or have other value, it could install
> something (for example binary files) in 'DESTDIR=$(CURDIR)/debian/tmp'
> and others (for example documents, for dh_installdocs order) in
> debian/spim. Or on the contrary, I don't remember very well.
> Something similar has happened to me sometime.

I don't understand this part... what should I change here?

You need more information? Please let me know.

Thanks again :)

Andrea Grandi
email: a.grandi at gmail.com
website: http://www.ptlug.org

More information about the maemo-developers mailing list