[maemo-developers] Uploading to Fremantle extras via Extras Assistant

From: Jeremiah Foster jeremiah at jeremiahfoster.com
Date: Fri Oct 16 19:00:27 EEST 2009
To have a newer package built in the autobuilder, you _have_ to change  
the version number to a newer version. You can do this with a new  
version of software, if you have a new version of software. If you are  
just changing the packaging, you change the packaging version. The  
packaging version is the part after the dash; i.e. 1.0-1 the -1 is the  
debian packaging version number. You can increment this, it will be  
considered a newer package and should build.

You have to do this in the debian/changelog - that is the  
authoritative location for versioning information for the package you  
are creating.

Please see the maemo policy and/or the debian policy for more version  


On Oct 16, 2009, at 17:36, Aniello Del Sorbo wrote:

> 2009/10/16 Anderson Lizardo <anderson.lizardo at openbossa.org>:
>> On Fri, Oct 16, 2009 at 10:57 AM, Aniello Del Sorbo  
>> <anidel at gmail.com> wrote:
>>> Sorry for spamming, any updates?
>>> I haven't changed anything, did someone change something on the  
>>> server side?
>>> Is there a log saying why it failed to process this changes file?
>> It seems that you didn't pass the "-S" flag to dpkg-buildpackage, as
>> explained on the main extras-assistant page. You need to create a
>> "source only" source package. In summary, use this command to  
>> generate
>> your sources for upload:
>> dpkg-buildpackage -us -uc -rfakeroot -S -sa
>> and make sure you upload the "..._source.changes" file, not other
>> _<arch>.changes file that might have create in previous builds.
>> PS: I think it would be nice that the extras-assistant checked for
>> this mistake (trying to upload a .changes file for a non source-only
>> build). I once had the same problem and it took me some time to  
>> figure
>> that out.
>> Regards,
>> --
>> Anderson Lizardo
>> OpenBossa Labs - INdT
>> Manaus - Brazil
> Thanks but, no it's not that. :(
> I used to upload the armel or i386 changes file and it always worked
> in fremantle-beta.
> But I tried your command, I also changed the changelog (now it's
> version 12 and it's new),
> but I still get the very same error.
> --
> anidel
> Sent from London, Eng, United Kingdom

More information about the maemo-developers mailing list