[maemo-developers] Not able to install Hildon Test Automation Framework on N900

From: Piñeiro apinheiro at igalia.com
Date: Wed Apr 7 14:05:29 EEST 2010
From: praveen koduru <prawin1111 at gmail.com>

> Thanks for the quick response Piñeiro.
> I tried your 2 steps. Please find the results below.
> Step 1:
> Nokia-N900-42-11:/home/opt# python
> Python 2.5.1 (r251:54863, May 23 2007, 17:32:51)
> [GCC 3.4.4 (release) (CodeSourcery ARM 2005q3-2)] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>>>> from dogtail import tree
> Creating logfile at /tmp/dogtail/logs/log_20100407-130759_debug ...
> Detecting distribution: Debian (or derived distribution)
> Warning: AT-SPI's desktop is visible but it has no children. Are you running
> any AT-SPI-aware applications?

Anyway, please check if at-spi is running.

>>>> tree.root.dump ()
> {root}
> (I have opened "contacts" and then did tree.root.dump(). but stilll giving
> {root} only)

As far as I remember arm-for testing just enable the accessibility
support for the applications included in the testing framework.

What it does is replace the launcher file application, in order to
launch the applications supported with GTK_MODULES=gail:hail:atk-bridge.

Remember that in maemo there are a maemo-launcher/invoker
application. Applications are loaded using this application.

I bet that contacts was not included in this framework, as it is a
really recent application.

You could try to modify by hand the contacts launch file, replacing
/usr/bin/osso-addresbook to something like this:

source /etc/osso-af-init/af-defines.sh
export GTK_MODULES=gail:hail:atk-bridge
exec maemo-summoner /usr/bin/osso-addressbook.launch

That is what arm-for-testing does (more or less, AFAIK) for the
supported applications.

Note: probably you should require to reboot the device after that.

> Step 2:
>>>> import atspi
> works fine; I tried the script you have given. script executed but with no
> prints
> Nokia-N900-42-11:/home/opt# ./Piñeiro.py
> Nokia-N900-42-11:/home/opt#

It doesn't print anything as no application is registered on at-spi.


API (apinheiro at igalia.com)
More information about the maemo-developers mailing list