[maemo-developers] Not able to install Hildon Test Automation Framework on N900

From: praveen koduru prawin1111 at gmail.com
Date: Thu Apr 8 13:28:13 EEST 2010
Hi Piñeiro,

at-spi is running.
Nokia-N900-42-11:/# ps aux | grep at-spi
 1795 root     13832 R    /usr/lib/at-spi/at-spi-registryd
 2458 root      2088 S    grep at-spi
I am able to run some applications on N900. But I am able to run only with
"dogtail.rawinput" functions.
Does it supports Object based refernce to the applications?.

Example. I have tried with Filemanager. I have launched the filemanager with
following command
GTK_MODULES=gail:hail:atk-bridge ossofilemanager

It launched filemanager and I am able to see "Nokia N900" folder in that.
and i tried tree.root.dump() and i have got
>>> tree.root.dump()
 Node roleName='application' name='ossofilemanager' description=''
  Node roleName='frame' name='File manager' description=''
   Node roleName='filler' name='' description=''
    Node roleName='filler' name='' description=''
     Node roleName='push button' name='' description='' text=''
      Node roleName='label' name='' description='' text=''
      Node roleName='label' name='' description='' text=''
     Node roleName='label' name='' description='' text=''
    Node roleName='panel' name='' description=''
 Node roleName='application' name='.' description=''
But I am not able to click the "Nokia N900" folder. I am not able to click
any object in the appliation. Please help


On Wed, Apr 7, 2010 at 7:25 PM, Piñeiro <apinheiro at igalia.com> wrote:

> From: praveen koduru <prawin1111 at gmail.com>
> > I have checked atspi is running or not like this
> >>>> import atspi
> >>>>
> > (no errors). Is this the way to check whether it is running or not??
> No, I mean something more simple:
> ps aux | grep at-spi
> > I am trying to get the object of "Calculator" app on N900. I really dont
> > know how to do that. where as on desktop I did like this for opening an
> > Totem application.
> > totem = tree.root.application('totem')
> > MovieMenu=totem.menu('Movie').click()
> > This justed worked on Desktop. Whereas to get the object of "Calculator "
> > App on Maemo. I did this
> > Calc=tree.root.application('/usr/bin/osso_calculator')
> > searching for child of {root}: "/usr/bin/osso_calculator" application
> > (attempt 3)
> > searching for child of {root}: "/usr/bin/osso_calculator" application
> > (attempt 4)
> > ... and the trying went on.
> As I told you before, arm-for-testing on doesn't enable a11y for all
> applications. Take into account that this link is for a automatic
> testing framework, so it only include some applications.
> In order to load the a11y modules, GTK_MODULES need to be set to
> GTK_MODULES=gail:hail:atk-bridge.
> arm-for-testing on change the launcher of the supported applications
> in order to be sure that GTK_MODULES has the correct values.
> > So could you please suggest me how to get the object of "Calculator" and
> > click one button with that.
> You could try the same suggestion I made in the previous mail related
> with the contacts application. Try to change the calculator launcher,
> in order to use the summoner and have the envvar with the correct
> value:
> >> #!/bin/sh
> >> source /etc/osso-af-init/af-defines.sh
> >> export GTK_MODULES=gail:hail:atk-bridge
> >> exec maemo-summoner /usr/bin/osso-addressbook.launch
> In the same way, you could create a simple gtk application, without
> maemo-launcher, and then try to execute it by hand in this way:
> $GTK_MODULES=gail:hail:atk-bridge ./my-gtk-application
> > Thanks a lot for your help.
> You are welcome, sorry for not be enough clear in my explanations, and
> thanks to test it. I have "Try if all a11y pieces works on n900" in my
> TODO list for a long time.
> > -Praveen
> BR
> ===
> API (apinheiro at igalia.com)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.maemo.org/pipermail/maemo-developers/attachments/20100408/2210d578/attachment.htm>
More information about the maemo-developers mailing list