[maemo-developers] Cannot get all indexes in Scratchbox doing an apt-get update

From: Andrea Grandi a.grandi at gmail.com
Date: Fri Jan 22 16:44:43 EET 2010
Hi guys,

2010/1/19 Andrea Grandi <a.grandi at gmail.com>:
> Hi,
> 2010/1/19 Jeff Moe <moe at blagblagblag.org>:
>> There was a problem with akamai. Apparently it was "flushed" and working now. See these logs and search for "Will take around 10 minutes for it to flush still." for some context:
>> http://mg.pov.lt/maemo-irclog/%23maemo.2010-01-19.log.html
> I'm still getting the same error, and I think 10 minutes have passed :D
> I'll try again tomorrow, thanks anyway ;)

I've tried today too, but I continue having the same error:

[sbox-FREMANTLE_X86: ~] > apt-get update
Ign http://repository.maemo.org fremantle/sdk Release.gpg
Ign http://repository.maemo.org fremantle/tools Release.gpg
Ign http://repository.maemo.org
Get:1 http://repository.maemo.org fremantle Release.gpg [489B]
Ign http://repository.maemo.org fremantle/sdk Release
Ign http://repository.maemo.org fremantle/tools Release
Ign http://repository.maemo.org
Get:2 http://repository.maemo.org fremantle Release [7958B]
Ign http://repository.maemo.org fremantle Release
Ign http://repository.maemo.org fremantle/sdk/free Packages/DiffIndex
Ign http://repository.maemo.org fremantle/sdk/non-free Packages/DiffIndex
Ign http://repository.maemo.org fremantle/sdk/free Sources/DiffIndex
Ign http://repository.maemo.org fremantle/tools/free Packages/DiffIndex
Ign http://repository.maemo.org fremantle/tools/non-free Packages/DiffIndex
Ign http://repository.maemo.org fremantle/tools/free Sources/DiffIndex
Ign http://repository.maemo.org
Ign http://repository.maemo.org fremantle/free Packages/DiffIndex
Ign http://repository.maemo.org fremantle/non-free Packages/DiffIndex
Hit http://repository.maemo.org fremantle/sdk/free Packages
Hit http://repository.maemo.org fremantle/sdk/non-free Packages
Get:3 http://repository.maemo.org fremantle/sdk/free Sources [87.4kB]
99% [3 Sources gzip 0] [Waiting for headers]
gzip: stdin: not in gzip format
Err http://repository.maemo.org fremantle/sdk/free Sources
  Sub-process gzip returned an error code (1)
Hit http://repository.maemo.org fremantle/tools/free Packages
Hit http://repository.maemo.org fremantle/tools/non-free Packages
Hit http://repository.maemo.org fremantle/tools/free Sources
Hit http://repository.maemo.org
fremantle/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/nokia-binaries Packages
Get:4 http://repository.maemo.org fremantle/free Packages [2631kB]
Get:5 http://repository.maemo.org fremantle/non-free Packages [8318B]
Fetched 2648kB in 9s (280kB/s)
Failed to fetch
 Sub-process gzip returned an error code (1)
Reading package lists... Done
W: GPG error: http://repository.maemo.org fremantle Release: Couldn't
access keyring: 'No such file or directory'
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old
ones used instead.

How can I fix this problem?

Andrea Grandi
email: a.grandi [AT] gmail [DOT] com
website: http://www.andreagrandi.it
PGP Key: http://www.andreagrandi.it/pgp_key.asc
More information about the maemo-developers mailing list