[maemo-users] [maemo-users] video playback fails most of the time

From: Brad Clements bkc at murkworks.com
Date: Fri Nov 18 01:51:42 EET 2005

I encoded some avi files that I have (640x480 DX50 64kbit audio), 
according to the instructions on this page:


Basically knocking it down to 352:208 with 15fps and DIVX fourcc.

80% of the time I try to play this 10 minute (28 meg) video, the 770 says 
"unable to open" file format not supported.

But a few times it has worked.

Interestingly, before it pops up that error, it sets the runtime length 
(bottom right) to 10 minutes.

I am playing from the MMC card.


If I want to stream video to the device, what is the recommended 
transport protocol and encoding? I'd like to try that..

Can the video player play 640x480? It should fit in full screen mode, I 
realize the refresh will be very low, that's ok.. 5fps would be ok..

Just rebooted and now it works.. well hey.

Now, I have an encoded one that's 640x480.. 

mencoder Grade_2_Spelling_Wk10_Les46-50_10-25-15_15_00.avi -endpos 10:00 -oac mp3lame 
-lameopts abr:br=64 -ovc lavc -lavcopts vcodec=mpeg4:mbd=1:vbitrate=300 -ffourcc DIVX 
-ofps 15000/1001 -o /tmp/test2.avi

If I try to play that, it fails (same generic error as above).

Then, I try to play the version that does work (352:208), and now it gives 
the error again.

I then exit and restart video player, and still, the file that "used to work" 
now doesn't work. But rebooting the device "fixes it" again so that the 
smaller sized one does work.

So, does exiting the video player really exit that process? Is the dsp 
getting whacked out from trying to play the larger video?

Brad Clements,                bkc at murkworks.com    (315)268-1000
AOL-IM or SKYPE: BKClements

More information about the maemo-users mailing list