[maemo-users] [maemo-users] Issues with RC6 and Maemopad / Tutorial?

From: Akkana Peck akkana at shallowsky.com
Date: Tue Nov 22 20:59:07 EET 2005
erkko.anttila at nokia.com writes:
> Were you following the tutorial part of "Building applications" step by
> step
> http://maemo.org/platform/docs/tutorials/Maemo_tutorial.html#Building-ap
> plications ? 
> We just tried it out and it functions perfectly, without problems. 

I'm still having problems with it.

First, it says to get Maemo_Dev_Platform_RS_v1.1rc5_i386.tgz, which
doesn't work with maemopad ("Requested 'hildon-libs >= 0.9.52' but
version of hildon-libs is 0.9.50").
http://maemo.org/downloads/download-sdk.html also says to use rc5.

If I use rc6 instead, I can get around that problem, and I can
build maemopad and install it (app-installer-tool install
maemopad_1.3_i386.deb). It shows up in the task navigator in xephyr,
but when I try to run it, it doesn't come up. There are tons of
warnings on stdout in scratchbox,, but it looks like the real problem is:

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

I had DISPLAY= in scratchbox before I ran af-sb-init.sh
start (of course). Did I miss a step in the tutorial? How do I set
up xephyr and scratchbox so that maemopad (run within xephyr) can
open the display?


More information about the maemo-users mailing list