[maemo-users] Gnumeric spreadsheet for N800

From: Marius Gedminas marius at pov.lt
Date: Mon Feb 26 21:29:57 EET 2007
On Mon, Feb 26, 2007 at 08:56:04PM +0200, Marius Vollmer wrote:
> "ext Marius Gedminas" <marius at pov.lt> writes:
> >> Can you say when it ran out of space?  During unpacking or during
> >> configuring (i.e., during running postinst, etc)?
> >
> > During unpacking, IIRC.
> Ok.  If it is a single package, then I wouldn't expect it to be
> "broken" afterwards, it should just not be listed as installed.  With
> multiple packages, however, things are more interesting...

I rebooted and tried again.

First time I got a "Download failed" dialog.  Log:

Installing gnumeric 1.7.0-1indt3
Failed to fetch http://www.maemo.org.br/platform/apt/pool/user/g/gnumeric/gnumeric-common_1.7.0-1indt3_all.deb: Error reading from server. Remote end closed connection
Failed to fetch http://www.maemo.org.br/platform/apt/pool/user/g/gnumeric/gnumeric_1.7.0-1indt3_armel.deb: Could not connect to www.maemo.org.br:80 ( - connect (111 Connection refused)

I tried again.  This time I got no download errors, but the package failed to install:

Installing gnumeric 1.7.0-1indt3
/bin/sh: /usr/sbin/dpkg-preconfigure: not found
Selecting previously deselected package libgnomecanvas2-common.
(Reading database ... 12891 files and directories currently installed.)
Unpacking libgnomecanvas2-common (from .../libgnomecanvas2-common_2.10.0-0ubuntu1_all.deb) ...
Selecting previously deselected package libgnomecanvas2-0.
Unpacking libgnomecanvas2-0 (from .../libgnomecanvas2-0_2.10.0-0ubuntu1_armel.deb) ...
Selecting previously deselected package libgnomeprint2.2-data.
Unpacking libgnomeprint2.2-data (from .../libgnomeprint2.2-data_2.10.3-0ubuntu1_all.deb) ...
Selecting previously deselected package libgnomeprint2.2-0.
Unpacking libgnomeprint2.2-0 (from .../libgnomeprint2.2-0_2.10.3-0ubuntu1_armel.deb) ...
Selecting previously deselected package libgnomeprintui2.2-common.
Unpacking libgnomeprintui2.2-common (from .../libgnomeprintui2.2-common_2.10.2-0ubuntu1_all.deb) ...
Selecting previously deselected package libgnomeprintui2.2-0.
Unpacking libgnomeprintui2.2-0 (from .../libgnomeprintui2.2-0_2.10.2-0ubuntu1_armel.deb) ...
Selecting previously deselected package libgsf-1-common.
Unpacking libgsf-1-common (from .../libgsf-1-common_1.14.1-2indt1_all.deb) ...
Selecting previously deselected package libgsf-1-114.
Unpacking libgsf-1-114 (from .../libgsf-1-114_1.14.1-2indt1_armel.deb) ...
Selecting previously deselected package libgoffice-0-common.
Unpacking libgoffice-0-common (from .../libgoffice-0-common_0.3.0-1_all.deb) ...
Selecting previously deselected package libgoffice-0-3.
Unpacking libgoffice-0-3 (from .../libgoffice-0-3_0.3.0-1_armel.deb) ...
Selecting previously deselected package libgsf-gnome-1-114.
Unpacking libgsf-gnome-1-114 (from .../libgsf-gnome-1-114_1.14.1-2indt1_armel.deb) ...
Unpacking gnumeric-common (from .../gnumeric-common_1.7.0-1indt3_all.deb) ...
dpkg: error processing /var/cache/apt/archives/gnumeric-common_1.7.0-1indt3_all.deb (--unpack):
 corrupted filesystem tarfile - corrupted package archive
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Selecting previously deselected package gnumeric.
Unpacking gnumeric (from .../gnumeric_1.7.0-1indt3_armel.deb) ...
/var/lib/dpkg/tmp.ci/preinst: 12: pgrep: not found
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Looks like apt leaves a half-downloaded file in /var/cache/apt/archives, and
doesn't retry the failed download.

It is very possible that I did the same thing (trying to install twice, with a
failed download in the middle) before.  I'm sort of doing this in the
background while working.

> > Heh, the "Installing" tab tells me gnumeric requires 32 megs of device
> > memory.  I have 24 megs free.  It would be nice if the application
> > manager checked the space requirement before installing.
> Yes, we could do that, but the involved numbers are really imprecise.
> They can be off by a factor of two or so, I'd say, in both directions.
> The package usually doesn't tell you how much space it really will
> take on a compressed file system like JFFS2, and a compressed
> filesystem like JFFS2 doesn't tell you how space really is free.

Ah, I see.  Makes sense.

Marius Gedminas
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.maemo.org/pipermail/maemo-users/attachments/20070226/21d7d298/attachment.pgp 
More information about the maemo-users mailing list