[maemo-users] Canola never finds any media

From: Steve Yelvington steve at yelvington.com
Date: Fri Sep 7 18:49:24 EEST 2007
José Luís wrote:
> Recently, I have this problem too. This is because, canola's 
> installation was no successfully finished . This happen in the 
> installation of avahi-daemon (canola dependency), because he try to 
> access /etc/shadow file, but is not present in the n800 device. To 
> solve this I used xterm to create a /etc/shadow file based on 
> /etc/passwd (see shadow file in any linux distribution, for details) . 
> After  creation of /etc/shadow file, you can use the command apt-get 
> install -f, to fix canola's installation.

This is probably my problem.

After posting my note last night, I ran apt-get from the command line 
(to install wget) and discovered a number of unprocessed configuration 
scripts, including avahi-daemon. To get avahi running I had to create 
both a user and a group.

At this point I'm probably going to have to reflash the unit over the 
weekend and start over, as I have managed to foul up Application 
Manager, which opens a window but won't run.

I've tried uninstalling/reinstalling Canola several times from the 
command line and undoubtedly have created a mess. I got as far as Canola 
finding the files but refusing to play any of them, but eventually fell 
back to the no-files problem.

I've only had this thing for a week. Consider it a dry run. :-)

More information about the maemo-users mailing list