[maemo-users] Battery life VERY short on N810, last OS2008...

From: Eero Tamminen eero.tamminen at nokia.com
Date: Mon Apr 21 17:58:16 EEST 2008

ext Giacomo Tufano wrote:
> On Mon, Apr 21, 2008 at 12:47 PM, Eero Tamminen <eero.tamminen at nokia.com> wrote:
>> ext Tony Green wrote:
>>> On Monday 21 Apr 2008, Giacomo Tufano wrote:
>>>> After installing the last revision of OS2008 (I don't really know why I did
>>>> it, because I had no problem on startup) battery life is very, very short. I
>>>> go from full battery down to automatic shutdown in a night...
>>> It certainly sounds like it's doing a lot of work. I've found that some
>>> applications hammer the battery just because they're loaded, even if they
>> One should note that any constant CPU usage, even 0.1%, is enough to
>> ruin use-time.
>> I would recommend running the "top" (or "htop") from SSH so that one
>> isn't confused about the XTerm updates. Also, applications using
>> maemo-launcher show up as "maemo-launcher" in top.  The real application
>> name can be seen with:
>>        cat /proc/PID/cmdline
>> If the application is "hildon-desktop" then it's one of the applets
>> draining the battery.
> I tried your suggestion (ssh remotely on the idle tablet). Tried to
> follow CPU usage for a while, then stopped and retried...
> The 'metalayer-crawler' is, apparently, idle (bad, I'd like a simple
> solution). :-(
> The only two processes that are using CPU (both at every check of top) are:
> 'cx3110x' and 'OMAP McSPI/0'
> I don't really know what those processes do, nor if they are related
> to the SSH connection.

They are.  They are kernel tasks, first one is related to WLAN and
second one is interrupt handler.  We need to look for the culprit
from elsewhere.

> But they're using CPU...
> A look at /proc/PID/status says 'SleepAVG' 91% ijust in case this is useful...
> Again, any hint to further proceeding is appreciated.

One possibility is a WLAN AP with broken power management, but then
things shouldn't get that much worse with newer OS release.   Another
possibility is some process using network often.

Could you try using "Offline mode" option from the power key menu?
If it helps significantly, then the issue is related to network.

Have you enabled RSS updates?  Do you leave e.g. Browser window
open when you don't use the device?

What applets you have enabled in Home?
If you do following from SSH after screen has blanked:
	strace -p $(pidof hildon-desktop|cut -d' ' -f1)
Is there any activity?

	- Eero

More information about the maemo-users mailing list