[maemo-users] Fighting through multiple notations identifying repositories.

From: hendrik at topoi.pooq.com hendrik at topoi.pooq.com
Date: Tue Dec 30 11:26:06 EET 2008
I'm trying to find and install a package, the setuptools for 
python2.5.  The package appears to be available online, but I have 
no success in getting the applicatin manager to see it.  What am I 
dong wrong?  And why do I have to translate betwen four different 
notations for describing repositories by trial and error?

I start by searching on gronmeyer.  Gronmeyer says:

Diablo maemo extras
diablo | free non-free 
Show packages
Dls: 10073
Status: Repository is online
last update: 10/06/2008 04:33:06 (GMT +0200)
python2.5-setuptools (v. 0.6c6-1osso3)

Let's call this notation number 1.

I try to enter this into my application manager.

I get the list of catalogues, and press 'New", and get a 'New catalogue' 
window where I get to fill in

Catalogue name:
Web address:
Components: user

This form is notation 2.

Now I suppose I get to choose a name for Catalogue name, but the obvious 
one is
	Diablo maemo extras

The web address is presumably

But what to dill in for Distribution and Components.?  Could it be
	free non-free
But what am I to do with the "user" that's already filled into the 
Components entry?

Presumably I don't check disabled.

Is is a failure of the gronmayer site that is isn't clear where all 
these words go?

I close, I check for updates, and look at the new package list.  I 
choose "all", but python2.5-setuptools is not available to be installed.

I reopen the repositories list, and it contains:

Diablo maemo extras - failed to refresh

Clicking on it tells me:

404 Not Found [IP: 80]

Call that notation number 3.

  There is indeed no user within 

But there is 'free'.  Even though the field called 'Components:" is 
tagged with a word in the plural, it seems to have ignored the 'free' 
and 'nonfree' I typed i there.  I'll go back and change that field.  
Instead of saying 'user free nonfree', it will just say 'free'.

OK.  Close.  Checking for updates.  Package still not there.  Back to 
Application manager->tools->application catalogue.

Diablo maemo extras is not on the list, but the package is still not 
present.  There certainly does exist a directory

Parent Directory                                                15.12.2008 02:43       -
python2.5-setuptools_0.6c6-1osso2_armel.deb                     30.06.2008 17:19  128788
python2.5-setuptools_0.6c6-1osso2_i386.deb                      30.06.2008 17:19  128778
python2.5-setuptools_0.6c6-1osso3_armel.deb                     24.09.2008 18:12  128778
python2.5-setuptools_0.6c6-1osso3_i386.deb                      24.09.2008 18:12  128760

so it sure looks as if there should be a package python2.5-setuptools.

Just to be complete, I'll mention notation number 4.  On web page 
there are a set of deb lines.

diablo extras

    deb http://repository.maemo.org/extras/ diablo free
    deb-src http://repository.maemo.org/extras/ diablo free 

This is notation 4.  Presumably I need

    deb http://repository.maemo.org/extras/ diablo free

I Log in as root. I look at /etc/apt/sources.list

It is empty -- a zero-length file.  Not what I had expected.  But 
which contains a file
It contains, at the end, the line 

deb http://repository.maemo.org/extras/ diablo free

which seems to be the correct notation-4 version of the repository I 

So tell me, why can the application manager not find the package?
And why are there so many notations without an obvious way to translate 
between them except for tedious trial and error?
And have I still done something wrong?

-- hendrik

More information about the maemo-users mailing list