[maemo-users] switching windows

From: Jeffrey Mark Siskind qobi at purdue.edu
Date: Wed Feb 6 04:46:10 EET 2008
   > I installed openssh on an N810. I logged into a remote Linux machine,
   > tunneling X, and ran emacs. The window came up on my N810 and I was able to
   > use the remote emacs (the very little that I tried). But I then clicked on the
   > "V" (i.e. the underlined down caret icon next to the X icon at the top of the
   >  -
   > window, which I presume is minimize). And then I was not able to reexpose and
   > reselect the window. While native app windows have icons that appear on the
   > left side of the root window, this did not. And when I click on the icon at
   > the llower left of the screen it popped up a menu of two windows but did not
   > include the remove X window.
   > Is there are way to reexpose/reselect/refocus a remove X window with the
   > default Maemo window manager?
   >     Jeff (http://www.ece.purdue.edu/~qobi)

   You need to have a .desktop file installed which specifies the WM_CLASS
   X property of that window (and preferably also an icon to use for it).

   You can see the properties Emacs uses with the "xprop" utility from
   the maemo x-debug-tools package:

Thanks for the tip. Can I ask for a little more help?

I created /usr/share/applications/hildon-navigator/emacs.desktop:

/usr/share/applications/hildon-navigator $ ls -l emacs.desktop 
-rw-r--r--    1 root     root           55 Feb  5 21:32 emacs.desktop
/usr/share/applications/hildon-navigator $ cat emacs.desktop
[Desktop Entry]

Then I did:

$ rm -rf /home/user/.osso

Then I rebooted. Then I ran emacs over ssh -X but was not able to select the
Emacs window.

~/.osso/hildon-desktop $ cat tasknavigator.conf 

What did I do wrong?

    Jeff (http://www.ece.purdue.edu/~qobi)

More information about the maemo-users mailing list