[maemo-users] N810 and Huawei E220 USB HSDPA modem

From: Joshua Layne joshua at willowisp.net
Date: Sat Feb 16 06:21:13 EET 2008
Tommy Persson wrote:
> Tommy Persson <tpe at ida.liu.se> writes:
>> I am trying to connect a Huawei E220 modem (HSDPA) to my N810. It
>> worked directly on my debian unstable machine. I have tried to compile
>> some additional modules like usbserial and use them but it does not
>> seem to work. Does anybody know if it is possible to get this to work
>> just compiling som extra modules or do I have to build a new image?
> I can report that by connecting the modem to a powered hub I got it to
> work by just insmod usbserial. I managed to create a ppp connection
> also so it works in principle. Now i just have to figure out how to
> configure it so it become convenient to use.
> But the power thing was irritating. The modem has two USB connections
> and one is only for power. So I connected an USB-battery that can give
> 700 mA to the power connection and still the N810 said that there was
> not enough power and failed to start things properly. I wonder if this
> just is a problem with power requirement detection. Can you disable
> this detection? I suspect that the modem does not see that it is
> connected to a battery and therefore reports that it needs a lot of
> power.
 From the brief spec I read on wikipedia today (because until today I 
had never heard of it), the second cord is only for power, but the first 
is for data+power and does in fact need power, but shouldn't require 
500mW on the primary.

This is all based on not much research, so I might be entirely wrong.

On the disabling of power detection, I believe that is a setting in the 
kernel (and so not easy to disable, intentionally), at least if it 
parallels the ?collie? zaurus - there was a discussion in the angstrom 
listserv a few weeks ago on it.


More information about the maemo-users mailing list