[maemo-users] emptied calendar

From: Hendrik Boom hendrik at topoi.pooq.com
Date: Wed Feb 20 22:25:29 EET 2008
On Mon, 18 Feb 2008 20:17:09 +0000, Hendrik Boom wrote:

> On Mon, 18 Feb 2008 19:26:33 +0100, Tommy Persson wrote:
>> Hendrik Boom <hendrik at topoi.pooq.com> writes:
>>> I tried posting on this yesterday, but the message seems to have gone
>>> astray.
>>> I've installed some gpe utilities on top of the factory-installed
>>> OS2007 on my N800.
>>> Yesterday, when I pulled my N800 out of my briedcase, I noticed that:
>>>   (1) it was already on
>>>   (2) the calendar program had lost *all* my appointments, although my
>>>   to-do list was intact.
>> I have had problems that files can not be read after a re-boot. Going
>> to the directory in an xterm solved that problem today. So have you
>> checked that the gpe-files are readable? Have you checked that the file
>> system has not been corrupted?

Well, I log in with an xterm.  The file .gpe/calendar is there, is 
readable by everyone and writable by the owner.  Doing 
  more .gpe/calendar
shows me a number of bits of ASCII string that is what I'd expect from 
the appointments I put in it.  If course, there's a lot of gibberish, but 
that's what I'd expect form a data base.  It's possible, if course, that 
some index the data base manager uses has been damaged, leaving the data 

If I recall correctly, gpe uses sqlite.  I suppose the next thing is to 
figure out how to dump the file using sqlite.  Maybe that will give us a 

-- hendrik

More information about the maemo-users mailing list