[maemo-users] extra blank line in shell buffer

From: Jeffrey Mark Siskind qobi at purdue.edu
Date: Tue Mar 4 23:13:49 EET 2008
   > When I run a shell buffer in emacs with the busybox shell, I get an extra
   > blank line after every command that I type (before the output of that
   > command). This doesn't happen with other shells in other Emacsen on other
   > platforms. How do I cause that not to happen?

   What's your terminal window size?

I'm running the shell inside a local emacs which I got from


(To get it to run I also had to install libxaw7-dev as it had a broken
dependency.) With the standard window manager (I believe that it is called
matchbox but I'm not sure) I don't know of any way to specify or change the
window sizes or positions. All windows appear to come up with the same size
and position. Even if I specify the -geometry option to emacs, it appears to
be ignored.

In any case, I'm running Emacs in window mode. With the default Emacs window
size and font, the shell buffer is 113 columns wide.

   I've noticed that at least when editing longer than one line commands
   in Busybox shell, it behaves strangely if window width is something
   else than 80.

I tried using stty in the shell buffer inside Emacs to change the cols
parameter to 80 and also enable and disable various newline carriage return
options but none seemed to have any effect.

I also tried running Emacs in -nw mode (i.e. in an osso xterm console rather
than a separate window). But it wouldn't start, complaining that terminal type
xterm was not defined. So I tried setting TERM to vt100 and it complaied that
terminal type vt100 was not defined.

    Jeff (http://www.ece.purdue.edu/~qobi)

More information about the maemo-users mailing list