[maemo-users] Solved. Was: Battery life VERY short on N810, last OS2008...

From: Giacomo Tufano gt at iltofa.it
Date: Thu May 1 12:23:31 EEST 2008
Battery problem has been solved. I had 1 critical issue and 2 minimal
ones on battery life.
First  and worst was pidgin. The software is very aggressive when the
net goes down. RTComm beta is more 'quiet'. I use it ever 'on'
autoconnecting when network is up. Pidgin, apparently, don't like this
Gnotifier also seems to be a battery eater, much less than pidgin.
Last problem in my home network. I have 2 apple ap in a wds network
(concrete building). If the tablet is left in the middle between the
two ap, this seems to hamper battery life. No special ideas on the
why. Just noticed it.
I'm now happy again, with ca. 4 days standby with moderate use. I was
just willing to share my findings in case someone else is hit, many
thanks for your support in debug this.
Tx, gt
ps: the last strange thing is that the battery applet says: '8 days',
goes down one day per day up to 4 and, then, the day after is empty.
Not a big problem, in reality. Battery indicators are, in my
experience, not more reliable in other cases (phones or notebook).

On 4/21/08, Giacomo Tufano <gt at iltofa.it> wrote:
> On Mon, Apr 21, 2008 at 4:58 PM, Eero Tamminen <eero.tamminen at nokia.com>
> wrote:
>>  One possibility is a WLAN AP with broken power management, but then
>>  things shouldn't get that much worse with newer OS release.   Another
>>  possibility is some process using network often.
>>  Could you try using "Offline mode" option from the power key menu?
>>  If it helps significantly, then the issue is related to network.
> I'll try this evening/night and I'll get back tomorrow with the results...
>>  Have you enabled RSS updates?  Do you leave e.g. Browser window
>>  open when you don't use the device?
> No (I hate programs polling automatically) :-). The only program
> polling is the gmail notifier...
>>  What applets you have enabled in Home?
> Internet search, web link (no change on standard URI), Tableteer info,
> clock and Internet Radio (never used, sitting idle).
>>  If you do following from SSH after screen has blanked:
>>         strace -p $(pidof hildon-desktop|cut -d' ' -f1)
>>  Is there any activity?
> I got (very fast) after the command:
> gettimeofday(whatever) = 0
> ioctl(3, FIONREAD, [0]) = 0
> gettimeofday(whatever) = 0
> poll(
> and then nothing else...
> To answer your question in a later email (so to try to save
> bandwidth): the device is not in R&D mode...
> It was before the upgrade, but I disabled the R&D mode after an email
> from you a week ago, or something like that explaining the problems
> with power management in this mode.
> Thinking about this, I did two things: upgraded the OS AND disabling
> R&D mode. But I think the latter can't be the problem, no?
> btw: I disinstalled Canola (the program is very complex, it is a
> candidate for problems/bugs).
> I'll try (in this order):
> leave the tablet "as is" (to test canola);
> if nothing leave the tablet with net disabled;
> if nothing I'll try to kill the metalayer-crawler (but I had no
> problem before, on N810 or on the 770 I used before this one and this
> tablet used to have power for 4 to 7 days)...
> If nothing the only other thing I can do is to reinstall OS2008 and,
> then, add an application every 2-3 days to isolate the battery
> offender...
> If there is something else I can try, feel free to suggest other
> option (I'm open). :-) If there are no other suggestion I'll post a
> success when I found the root cause...
> Thank you all for your help and support,
> gt

More information about the maemo-users mailing list