[maemo-users] Emacs and libxaw7

From: Eric S Fraga ucecesf at ucl.ac.uk
Date: Mon Aug 3 01:46:23 EEST 2009
At Sun, 02 Aug 2009 13:08:31 +0100,
Peter Flynn wrote:


> But I take back what I said, there *is* a pointer at the end of this 
> thread http://talk.maemo.org/showthread.php?t=16189&page=7 to a chinook 
> version of all three libx libraries which appear to work for emacs.

Yes, the chinook version is what I ended up using.

> However, the emacs package is still broken as shipped: when you execute 
> the binary emacs, you get
> > Warning: arch-dependent data dir (/usr/libexec/emacs/22.1/arm-linux-gnueabi/) does not exist.
> > Warning: arch-independent data dir (/usr/share/emacs/22.1/etc/) does not exist.
> > Warning: Lisp directory `/usr/share/emacs/22.1/site-lisp' does not exist.
> > Warning: Lisp directory `/usr/share/emacs/site-lisp' does not exist.
> > Warning: Lisp directory `/usr/share/emacs/22.1/lisp' does not exist.
> > Warning: Lisp directory `/usr/share/emacs/22.1/leim' does not exist.
> All exist in my install target on /media/mmc1/emacs so they're easily 
> fudged by linking them back to the absolute path, but this ought to have 
> been done by the install script.

Well, I'm not sure what you mean by the install script but if you had
done simply "dpkg --install emacs-X.deb" (where X is replaced by the
versioning information), it would have done things right (it did for
me).  By installing somewhere else, dpkg cannot make arbitrary links
so you need to do these yourself directly (which I also did when I
first installed emacs).

>  > Cannot open load file: term/x-win
> Dunno where this is or where it's supposed to be, but emacs now
> executes :-)

I didn't get this problem.  Not sure why but possibly because I had
first tried the non-X version of Emacs which required ncurses-base to
be installed and that may have provided the terminfo entry required.

> Getting it full-screen is more difficult: the thread I referred to tails 
> off with the post from Eric saying
>  > Excellent.  Thanks.  I'll pursue this avenue.
> Eric: did you manage to get this to work? The suggestion you refer to 
> (Googling wmctrl maemo xbindkeys, made by Damien) turns up this thread, 
> a bunch of listing, some Python, and some posts in Japanese, but no 
> actual hint of what packages are needed or what command/configs will 
> make Emacs run full-screen.

Well, I kind of chickened out in the end and bought myself (this past
week) an N810... the hardware keyboard frees up enough screen space
that I no longer need the X version of Emacs (happy to run the non-X
version in a ROXTerm although less happy in the osso-xterm which
occupies too much space with frippery... [1]).

> Incidentally, now it's installed and executing, how do I add it to the 
> system menu so that I don't need to invoke it from a command in the 
> xterm window?

I don't know about the system menu but, I believe, you should be able
to install any arbitrary command into the "personal menu" (which is
introduced by an application you can install).  I've not tried this,
mind you.


[1]  In case anybody can help, I have two niggles left in my
configuration of the 810 for Emacs use.  I'm using roxterm to get free
up the screen space used by osso-xterm for the "Tab Esc ..." line but
that means that I don't have a tab key (okay, I can type C-i,
obviously but that's also difficult).  Is it possible to remap the Chr
key on the hardware keyboard to generate the tab (or anything else for
that matter)?  A second question: is it possible to also get rid of
the "line" on the screen that is displayed as soon as you start using
the hardware keyboard, the line that displays "abc", "Abc", "ABC" or
"Fn" as the case may be?  I don't need that kind of visual feedback...

More information about the maemo-users mailing list