[maemo-users] Qt installation problem in DIABLO

From: Kimitake kimitake at gmail.com
Date: Mon Aug 10 07:29:38 EEST 2009

1) 4.5.2-1maemo2 is in extras-devel, so you can find it since
you apt/source.list has the following line.

deb http://repository.maemo.org/extras-devel/ diablo free non-free

2) To remove qt packages, usually I use the following command
apt-get remove --purge libqtcore4
if you have qt4-qmake also, you need to run the following also
apt-get remove --purge qt4-qmake

and then install libqt4-dev as follow
apt-get install libqt4-dev

In addition, you can make sure which version you install as follow.
dpkg -l | grep qt

And if you haven't checked the Qt4 Hildon wiki[1], please refer it also.

[1] http://wiki.maemo.org/Qt4Hildon


On Sun, Aug 9, 2009 at 10:47 AM, Abhrodeep Nag<abhrodeep_nag at yahoo.co.in> wrote:
> Hi,
>       Thanks for your reply. I am also new in this field thus want your
> help. I did what ever are needed as described in my below mail and whatever
> the link I gave in the source.list file that also I have shared with you
> people. I just want to know
> 1) how shall I get 4.5.2-1maemo2 version
> 2) last time I removed entire scratchbox then reinstalled it from the
> begining, this time I want to know from you how to remove only Qt package
> from the scratchbox, I tried to remove package using commands available
> related to apt-get but it was not worked out, I was getting some errors
> Looking forward towards your help.
> ******************************
> With Warm Regards,
> Abhrodeep Nag
> ________________________________
> From: Kimitake <kimitake at gmail.com>
> To: Abhrodeep Nag <abhrodeep_nag at yahoo.co.in>
> Cc: maemo-users at maemo.org; qt4-devel at garage.maemo.org
> Sent: Sunday, 9 August, 2009 8:31:42 AM
> Subject: Re: Qt installation problem in DIABLO
> Hi,
> I just remove qt packages from my scratchbox and reinstalled libqt4-dev,
> but I have not got any error during installing it.
> The latest one is 4.5.2-1maemo2 and it exists in extras-devel.
> Did you install it?
> Regards,
> Kimitake
> On Thu, Aug 6, 2009 at 11:31 AM, Abhrodeep Nag<abhrodeep_nag at yahoo.co.in>
> wrote:
>> Hi,
>> In the source.list I have given following link
>> deb http://repository.maemo.org/extras/ diablo free non-free
>> deb-src http://repository.maemo.org/extras/ diablo free
>> deb http://repository.maemo.org/extras-devel/ diablo free non-free
>> deb-src http://repository.maemo.org/extras-devel/ diablo free
>> Then I have executed from inside scratchbox "apt-get update" followed by
>> "fakeroot apt-get install libqt4-dev"
>> During installation I am getting errors "- lqtguitools not
>> found.....Broken
>> packages".
>> I got stuck due to this problem for last 3 days please tell me the way out
>> clearly. I am also new in this field so need to know elaborately what ever
>> you are suggesting me.
>> Regards,
>> Abhrodeep Nag
>> ________________________________
>> See the Web's breaking stories, chosen by people like you. Check out
>> Yahoo!
>> Buzz.
>> _______________________________________________
>> maemo-users mailing list
>> maemo-users at maemo.org
>> https://lists.maemo.org/mailman/listinfo/maemo-users
> ________________________________
> Yahoo! recommends that you upgrade to the new and safer Internet Explorer 8.
More information about the maemo-users mailing list