[maemo-users] Help with Maemo Virtual Image Install Documentation

From: R. G. Newbury newbury at mandamus.org
Date: Thu Nov 12 20:58:43 EET 2009
Well I finally got the Maemo SDK Virtual Image installed. A very 
frustrating experience, having been mislead repeatedly by the 
documentation and the install script. More by errors of omission.
Everything actually DID work, and I now have Ubuntu installed in a 
virtualbox, but man it was FRUSTRATING.

<semi-rant begins>
I downloaded 
and ...002. (And then I then had to find, build and install 7zip.....)

I ran 7za x Maemo.....001 and it ran. I tried to do the same for ...002 
and got a 'Not an archive' error. I had no idea if 7za dealt with both 
files serially, or if the file was corrupt.

A little explanation in the documentation would be helpful. How about 
telling us what the proper result will be?

"7Za will serially extract the split numbered zip files, and report:
'Everything is Ok

Files: 5
Size:       8453907228
Compressed: 1572864000'"

Then we run the installer script, which is a fun guessing game. It asks 
for information without the slightest hint as to the expected response 
and uses misleading names for the information. HOW ABOUT A HINT?
"Location of VirtualBox binaries (normally /usr/bin)?"

Then it asks for "The name of your VirtualBox Image." Off the bat, I 
thought that was the name of the image file. But what is wanted is not 
actually the name of the file, but a name under which your virtual 
instance will appear in the Manager. It has nothing to do with the name 
of the vdmk file. A short alias is what is wanted. Of course, I inserted 
the name of the file: maemosdk_desktop_intrepid-10-08.vmdk. Since I had 
already manually created a virtual instance, I now had 3 instances 
(including the pre-existing WinXP), one of which had an unreadable name, 
due to its length.
How about:

"Please provide a (short) name for this virtual instance. This name will 
appear in the list of virtual instances in the VirtualBox Manager 

Finally, it asks for the "location" of the VirtualBox image. But what it 
wants is not actually the location of the image. Generally a 'location' 
for a file is the folder 'where' it is. The script actually wants the 
'what' of the file: the fully qualified pathname of the image file. That 
is: /tmp/downloads/maemosdk_desktop_intrepid-10-08.vmdk or whatever.

So how about:
"Please provide the full pathname of the vmdk file 

Of course, what is NOT discussed, is that this script will create the 
virtual hard-drive instance *out of the vmdk* and exactly where the vmdk 
presently resides. Yes, of course I wanted to create a virtual in my 
/tmp/downloads folder. Although a different place would be better.....

I had to parse the script, and read 'VBoxManage --help' to understand 
what the script was trying to do. Once I got past being misdirected, I 
was able to install. Only took me about 2 hours, not including download 


Now that I do have it installed, I must congratulate those who put this 
together. Despite my frustrations at the installer, it probably took 
less time than I expended each time, when I tried to install scratchbox 
versions 1 or 2. I strongly suspect that the script was run up in short 
order by someone who knew *exactly* what he wanted, and therefor could 
not see the forest for the trees.


         Please let me know if anything I say offends you.
          I may wish to offend you again in the future.

          Tux says: "Be regular. Eat cron flakes."
More information about the maemo-users mailing list