[maemo-users] Help with Maemo Virtual Image Install Documentation

From: R. G. Newbury newbury at mandamus.org
Date: Sat Nov 14 01:16:33 EET 2009
Thanks for the constructive reply.
My further comments in-line, with lots of extraneous stuff deleted.


Jarmo.Tikka at nokia.com wrote:
> Hi,
> And thanks a lot about Maemo SDK Virtual Image feedback. I added also another mailing list into this response (people constructing our images read more that list).
> Some comments below.
>> in a virtualbox, but man it was FRUSTRATING.
> Great that you actually explained below why you were frustrated :) so that we can comment and even fix issues.

That was the exact point. It DID work, but I spent a couple of hours 
trying various combinations of stuff, including creating virtuals in 
VirtualBox because what I was trying did not work (This, despite the 
fact that the documentation strongly implied that I did not have to do 
that. It was correct, but I was doing the wrong things.

>> <semi-rant begins>
>> I downloaded
>> Maemo_PreFinal_2_Ubuntu_Intrepid_Desktop_SDK_Virtual_Image_Spli
> tted.zip.001
>> and ...002. (And then I then had to find, build and install 7zip.....)
>> I ran 7za x Maemo.....001 and it ran. I tried to do the same 
>> for ...002 and got a 'Not an archive' error. I had no idea if 
>> 7za dealt with both files serially, or if the file was corrupt.
>> A little explanation in the documentation would be helpful. 
>> How about telling us what the proper result will be?
>> "7Za will serially extract the split numbered zip files, and report:
>> 'Everything is Ok
>> Files: 5
>> Size:       8453907228
>> Compressed: 1572864000'"
> We have a problem that most standard compression tools have restriction about 2GB max file size. Compression tools I know which are commonly available and cabable of handling > 2GB archives are 7-Zip and WinZip. Because 7-Zip is free and available also for Linux we decided to use it for compression. 7-Zip is cabable of creating compatible zip format with other tools (like WinZip) but splitted archives are not compatible.
> Why we then use splited archives :). Well our download page for image distribution archive files has been implemented with PHP and PHP seems to have that same max file size limit. Actually PHP limit sems to be for some odd reason smaller than 2 GB.

I thought that that might be the reason for splitting the files. I 
didn't particularly mind finding and installing 7zip. What bothered me 
was that I had no idea of what the process was, or what the result 
*should* be. And you already know that, so you could have told me!

>> Then we run the installer script, which is a fun guessing 
>> game. It asks for information without the slightest hint as to 
>> the expected response and uses misleading names for the 
>> information. HOW ABOUT A HINT?
>> "Location of VirtualBox binaries (normally /usr/bin)?"
>> Then it asks for "The name of your VirtualBox Image." Off the 
>> bat, I thought that was the name of the image file. But what 
>> is wanted is not actually the name of the file, but a name 
>> under which your virtual instance will appear in the Manager. 
>> It has nothing to do with the name of the vdmk file. A short 
>> alias is what is wanted. Of course, I inserted the name of the 
>> file: maemosdk_desktop_intrepid-10-08.vmdk. Since I had 
>> already manually created a virtual instance, I now had 3 
>> instances (including the pre-existing WinXP), one of which had 
>> an unreadable name, due to its length.
>> How about:
>> "Please provide a (short) name for this virtual instance. This 
>> name will appear in the list of virtual instances in the 
>> VirtualBox Manager (Maemosdk-2)"
>> Finally, it asks for the "location" of the VirtualBox image. 
>> But what it wants is not actually the location of the image. 
>> Generally a 'location' 
>> for a file is the folder 'where' it is. The script actually 
>> wants the 'what' of the file: the fully qualified pathname of 
>> the image file. That
>> is: /tmp/downloads/maemosdk_desktop_intrepid-10-08.vmdk or whatever.
>> So how about:
>> "Please provide the full pathname of the vmdk file 
>> (/tmp/downloads/maemo-xxx.vmdk)"
>> Of course, what is NOT discussed, is that this script will 
>> create the virtual hard-drive instance *out of the vmdk* and 
>> exactly where the vmdk presently resides. Yes, of course I 
>> wanted to create a virtual in my /tmp/downloads folder. 
>> Although a different place would be better.....
>> I had to parse the script, and read 'VBoxManage --help' to 
>> understand what the script was trying to do. Once I got past 
>> being misdirected, I was able to install. Only took me about 2 
>> hours, not including download time..
>> </semi-rant>
> These are just usability problems with our instalaltion script. I think we can fix all these issues for our final image.
> Raul can you confirm that we really can fix these?

> We have not had so much time for usability and instalaltion issues as we have concentrated on functionality.
> For the final version we can check what can be done to even more simplify installation process.
> Thanks a lot about comments.

Fixing this is easy. I will revise the script, including adding a stanza 
to allow installation in another spot and e-mail you.

I'm glad to know that someone is listening, and I am glad to help where 
I can. I had a hard time installing scratchbox-1 and a I cannot being to 
  figure out how you were able to encapsulate an entire ubuntu install 
with scratchbox etc into one installable virtual image. That's about 5 
or 6 magic spells in a row!


         Please let me know if anything I say offends you.
          I may wish to offend you again in the future.

          Tux says: "Be regular. Eat cron flakes."
More information about the maemo-users mailing list