[maemo-users] gst-launch and openmax

From: Aldon Hynes Aldon.Hynes at Orient-Lodge.com
Date: Wed Jan 27 04:01:04 EET 2010
I am new to using gst-launch.  I've not been able to find good descriptions
of the different options or elements to use.  So, I started by using

gst-launch v4l2camsrc device=/dev/video1 num-buffers=1 ! videoscale !
video/x-raw-yuv,width=475,height=356 ! omx_jpegenc ! filesink

That gave me the error about omx_jpegenc

When I tried using jpegenc instead of omx_jpegenc I got a message:
could not link videoscale0 to jpegenc0

I tried dropping videoscale, I tried using pngenc, none of these worked.
The suggestion about dspjpegenc worked nicely, except that the images turned
out all black or all white.  Is there a png counterpart?  I also tried
adding capture-mode=1 to the v4l2camsrc element, which didn't make any

I haven't done anything with ffmpegcolorspace, so I'll look at that next.

If you know of any good documentation on using the gst-tools, that would be
greatly appreciated.


-----Original Message-----
From: Attila Csipa [mailto:maemo at csipa.in.rs]
Sent: Tuesday, January 26, 2010 6:42 PM
To: maemo-users at maemo.org
Cc: Aldon Hynes
Subject: Re: gst-launch and openmax

On Tuesday 26 January 2010 23:21:49 Aldon Hynes wrote:
> When I tried jpegenc I got
> WARNING: erroneous pipeline: could not link v4l2camsrc0 to jpegenc0
> When I tried pngenc I got
> WARNING: erroneous pipeline: could not link v4l2camsrc0 to pngenc0
> When I tried dspjpegenc, it captured a picture, but my image was all

Can you post the whole pipeline you're using ? Seems you're missing an
(likely ffmpegcolorspace or sorts).


More information about the maemo-users mailing list