[maemo-developers] [maemo-developers] superuser privilege to install apps

From: Christine Liu liuliuliu at gmail.com
Date: Tue May 2 03:49:51 EEST 2006
hello all -

i just started playing around with maemo today, and i'm really excited
to be joining the team of developers!

one question - i am going through the maemo sdk tutorial online and am
in the part where you install the application 'maemopad.'  everything
is great, it compiles and i get the debian package.

however when i try to install using app-installer-tool it says i must
have su privileges to install (dpgk: requested operation requires
superuser privilege). i tried logging in (in the scratchbox shell)
with my normal root password on my machine but it didnt seem to like
that. i also tried logging into scratchbox as machine root but that
didnt work either ("ERROR: not allowed to run this as root!")

i tried googling for this problem to no avail. if anyone could point
out the obvious remedy, that would be so helpful. thank you!


More information about the maemo-developers mailing list