[maemo-developers] [maemo-developers] superuser privilege to install apps

From: Philippe De Swert Philippedeswert at scarlet.be
Date: Tue May 2 23:20:20 EEST 2006

On Mon, 2006-05-01 at 20:49 -0400, Christine Liu wrote:
> hello all -
> i just started playing around with maemo today, and i'm really excited
> to be joining the team of developers!

Great! Good luck and happy hacking!

> one question - i am going through the maemo sdk tutorial online and am
> in the part where you install the application 'maemopad.'  everything
> is great, it compiles and i get the debian package.
> however when i try to install using app-installer-tool it says i must
> have su privileges to install (dpgk: requested operation requires
> superuser privilege). i tried logging in (in the scratchbox shell)
> with my normal root password on my machine but it didnt seem to like
> that. i also tried logging into scratchbox as machine root but that
> didnt work either ("ERROR: not allowed to run this as root!")

You need to use fakeroot inside scratchbox to install an application (or
run the app-installer-tool I guess...)

Installing a deb package is easy. Just do fakeroot dpkg
-i /path-to/packagename.deb

Hopes this helps,


| Philippe De Swert       
| GPE developer: http://gpe.handhelds.org
| Emdebian developer: http://www.emdebian.org  
| Please do not send me documents in a closed
| format.(*.doc,*.xls,*.ppt)    
| Use the open alternatives. (*.pdf,*.ps,*.html,*.txt)    
| http://www.gnu.org/philosophy/no-word-attachments.html  

More information about the maemo-developers mailing list