[maemo-developers] [maemo-developers] desktop integration

From: Tomas Frydrych tf at o-hand.com
Date: Tue May 9 14:18:18 EEST 2006

been there and this works for me:

Application Desktop file

    * The X-Osso-Service line must not contain a fully qualified name,
you want something like


    * Must include at least one of the Exec or StartupWMClass lines,
otherwise there will be no icon in the Task Navigator panel for your

Application Service file

    * Call your service com.nokia.myapp where myapp is whatever you put
into the X-Osso-Service line in the desktop file:


Danny Milosavljevic wrote:
> Hi,
> Oookay...
> I just spent four hours trying to find out how 
> to integrate an application into the maemo
> environment.
> Now that was unneccesary and I'm giving up 
> for now, hoping for help.
> I ported a nice little program to maemo
> (see http://www.scratchpost.org/nokia-770/packages/ ),
> and it worked fine, when started from xterm.
> When I tried to start by using the application 
> menu, however, my osso_initialize call  
> failed.
> By now I tried every single one of the ~ 43000 (j/k)
> combinations that could be valid in the
> - desktop file
> - service file content
> - service file name
> - osso_initialize call name
> - osso_initialize call version
> - osso_initialize call activation
> And it just doesn't work.
> For now I commented out the osso parts and now it 
> can be launched from the menu. :)
> However, stangely enough, now the application icon 
> of the menu entry is gone. It was there before I
> commented out the service stuff. I didn't comment 
> out "Icon=", it's still there.
> Helppp :)
> And before I don't forget, a few nitpickings about the
> tutorial:
> -
> On
> http://www.maemo.org/platform/docs/tutorials/Maemo_tutorial.html#LibOSSO-library
>   there is no mention how the include file needed
>   for libosso is called (until waaaay down).
> - the osso_initialize example uses a partial 
>   dbus service name only, and isn't the 
>   third parameter deprecated by now?
> - I sure hope the weird voodoo done by 
>   osso_initialize (magically prefixing
>   "com.nokia.") is already gone? If not, it's 
>   not mentioned. 
> - And the example doesn't use "com.nokia", 
>   but "org.maemo". Which would make it break in 
>   mysterious ways.
> - the valid chars in the dbus service name are not
>   mentioned (and there is no NO DASHES warning)
> - "Icon – Name of icon that represents this application" 
>   (in tutorial) says:
>   "Format of the file should be PNG and the prefix (.png) 
>   should not be defined."
>   That is probably a suffix, and my voodoo detector goes 
>   off again.
>   Don't ever do that. The file is called how it is called,
>   no adding/removing stuff to *cough* "simplify" it please.
> Phiew... now I need sleep. Good night :)
> cheers,
>   Danny

More information about the maemo-developers mailing list