[maemo-developers] Installing NFS

From: marc zonzon marc.zonzon at gmail.com
Date: Fri Apr 13 10:04:22 EEST 2007
I have also some problem with nfs, I have installed nfs-common and
rx-34-kernel-nfs-modules,  portmap start, the modules load:
Module                  Size     Used by
nfs                       227248   0 - Live 0xbf0b8000
lockd                     61396   1 nfs, Live 0xbf0a8000
sunrpc                 146048   2 nfs,lockd, Live 0xbf083000

But I cannot mount a nfs:
# mount  -t nfs /media/nfs
mount: Mounting on /media/nfs failed: Invalid argument

I previously tried the kernel "Linux N800 with Ext2/3, smbfs and nfs"
with builtin nfs, and got the same result.

Does anybody can truly achieve an nfs mount ?


On 4/10/07, Jeffrey Barish <jeff_barish at earthlink.net> wrote:
> Frantisek Dufka wrote:
> > In fact you don't need another kernel. You just need nfs kernel modules.
> > I think they are in bora repository so you can apt-get them on device
> >
> > [sbox-SDK_ARMEL: ~] > apt-cache search nfs
> > rx-34-kernel-nfs-modules - NFS modules for rx-34 kernel
> > nfs-common - NFS support files common to client and server
> > portmap - The RPC portmapper
> I like this suggestion, but the nfs-common package is broken:
> The following packages have unmet dependencies:
>   nfs-common: Depends: adduser but it is not installable
> E: Broken packages

More information about the maemo-developers mailing list