[maemo-developers] Newer glib on Maemo5

From: Claudio Saavedra csaavedra at igalia.com
Date: Tue Nov 17 17:20:41 EET 2009
El mar, 17-11-2009 a las 10:08 -0500, Zachary Goldberg escribió:
> Hello!
> I have an application I am trying to port to Maemo 5 that requires a
> newer version of libglib2.0 (2.22) than what is on the device (2.16).
> Does anybody know what horrible things might happen if I brute-force a
> 2.22 (and its newer dependencies) on the device?  Is there anyway
> around this problem (perhaps some kind of copy on write chroot with a
> symlinked version of everything but glib and co?)?

Maemo 5 currently has glib 2.20 (2.20.3-1maemo3). In theory, upgrading
to glib 2.22 shouldn't be a problem, but I am not aware of any plans to
do it at this stage.

If you want to experiment, you can get the debian packaging bits from


and build a glib 2.22 starting from that.


More information about the maemo-developers mailing list