[maemo-developers] Newer glib on Maemo5

From: Andrea Borgia andrea at borgia.bo.it
Date: Tue Nov 17 17:52:30 EET 2009
Zachary Goldberg ha scritto:

> I have an application I am trying to port to Maemo 5 that requires a
> newer version of libglib2.0 (2.22) than what is on the device (2.16).
> Does anybody know what horrible things might happen if I brute-force a
> 2.22 (and its newer dependencies) on the device? 

Speaking as an expert ;-) on the topic of "bad things" that can happen
when overriding a core library, I would try either relaxing the
dependency (if possible) or statically linking just that library.


More information about the maemo-developers mailing list