[maemo-developers] Getting package with lower version into extras-testing

From: Graham Cobb g+770 at cobb.uk.net
Date: Tue Oct 13 16:20:23 EEST 2009
On Tuesday 13 October 2009 13:46:25 Cornelius Hald wrote:
> Sorry to be so persistent, but I still don´t understand why I should
> have two packages.

You are probably right that the root cause of the problem is that we are using 
extras-devel for two different purposes: it is a test area for very early 
versions of packages as well an important step on the way for packages trying 
to get to the users.  Sometime we may have to split that up.

However, at the moment, your requirement is unusual.  The current rules 
(autobuilder checks that it is building a newer version, and the promotion 
interface only shows the latest version) help prevent lots of mistakes, 
particularly by people who are not too familiar with packaging.  I would not 
want to change them.

So, I understand what you are trying to do and why but I think the current 
rules do more good than harm.  You seem to have a few options: (i) only use 
extras-devel once you are close to calling a new version stable and are 
unlikely to do any more updates to the previous version (you could use a 
private repository, like I still do for the daily builds from SVN for my 
software), (ii) use different package names (upgrades should work if you are 
using Conflicts: & Replaces:), (iii) hack with version numbers using epochs.

Let's see how many packages find this a problem before we look at changing 

More information about the maemo-developers mailing list