[maemo-developers] Getting package with lower version into extras-testing

From: Cornelius Hald hald at icandy.de
Date: Tue Oct 13 18:04:09 EEST 2009
On Tue, 2009-10-13 at 15:09 +0200, Tim Teulings wrote:
> All well thoughtout, but one problem: If you later on find a bug in 0.5.x
> and you will upload 0.5.y (where y>x) to get that fix into testing, at
> least in extras-devel nobody will be able to download it, because the
> application manager wil never show it. It will only and always show
> 0.6-alphaX. And if you have 0.6.0 in extras-testing (where it possibly
> stays for lets say one month) and in the mean time you promote your 0.5.y
> fix (because it works), no tester will see it in the application manager
> either (they will only see 0.6.0). They all would need to download and
> install it manually to the device (and you have to support this downgrading
> in your packages).

Thanks for giving that special case. There indeed I see a problem. I
don't think it would be a particular problem for me, but I can see, that
it might be a problem for other (or even for me at some point). 

> No problem. Is it clearer now?

Yes, it's clearer now. Thank you :) Also big thanks to Graham for the
explanation and the tips with 'Conflicts' and 'Replaces'. I'll give it a
try now. Let's see how it goes.


More information about the maemo-developers mailing list