[maemo-users] [maemo-users] Nokia 770 NO LONGER BOOTS

From: Andy Mulhearn unxmully at mac.com
Date: Sun Dec 11 00:38:44 EET 2005
Matthew P. Johnson wrote:

>Hi all,
>I got my Nokia 770 a few days ago and was having trouble connecting to
>Wifi. Tech support told me to shut down, remove the battery, and
>restart. This was annoying, but it worked. While online, I installed a
>few apps (xterm, ssh, GAIM, etc.), and tried setting my path in
>/home/user/.profile to include the install directory, as well as \bin
>and . I didn't include \sbin, but my change to .profile didn't seem to
>have any effect anyway.

I suspect this has nothing to do with the problem but I believe it's a 
bad idea to add the current directory (.) to your path. It has all sorts 
of possible security implications.

>The next day I had the wifi problem again, so I removed the battery
>and tried to restart. Now it fails to boot. The Nokia screen (not the
>hands, just the Nokia name) comes up and the progress bar starts
>moving, but at a certain (apparently random) point, the screen
>flashes, and the progress bar starts over, at the left. This continues
>to repeat until I remove the battery to turn it off.

This is a pain, if there was some way to enable the standard linux style 
boot messages, at least you'd have some idea of where things are going 
wrong :(

>I called tech support again. They said they had never heard of this
>problem, and told me to exchange it at CompUSA, which is difficult for
>obvious reasons. (Also, I'd like to find out exactly what caused this,
>so it doesn't happen again. I don't have a lot of Linux experience,
>but could the .profile be messing up the boot script?) I tried running
>the update software from the Nokia Europe website. This starts up, but
>fails at a certain point with "error code: ?". There's the flasher
>software, with which I could reboot r&d mode and get root (and delete
>.profile or at least see debug info on startup), but I don't have a
>Linux box or Mac handy.
Ordinarily your profile is not executed as part of the boot sequence, 
but this is not an ordinary Linux system so who knows :(

Anyway, I've not seen or heard of a problem like this on either this 
list or at the Internet Tablet Talk (www.internettablettalk.com) web 
site, though there have been some reported problems with flashing the 
binary from Nokia's site. Have a go with the binary you can download 
from here http://maemo.org/downloads/nokia_770

This is a slightly later build than is available from the Nokia site (-8 
as opposed to -7) and seems to work better than the one from Nokia, as 
in it has flashed in some cases where the Nokia one doesn't.

There have also been some rare wireless hardware problems reported - one 
of the first reviewers had a bad device - so it may be just that you got 
a bad one and the return to Compusa is your only recourse.

Throwing this at maemo-developers may get a better response from some of 
the more hardcore hackers.

Hope this helps and sorry you're having problems with your 770,


More information about the maemo-users mailing list