[maemo-users] [maemo-users] An osso-xterm question

From: Stefan Boresch stefan at mdy.univie.ac.at
Date: Wed Jan 18 18:55:48 EET 2006
If I start osso-xterm (installed normally by the application installer
from http://770.fs-security.com/xterm/) the shell is in the / directory.
However, I would very much like to have the shell running in the xterm be
in ~ (i.e., /home/users, which is my $HOME). 

I must be overlooking
something trivial. I tried among other things to make a my-xterm.desktop
file, replacing the Exec= Exec entry of 0301_osso_xterm.desktop by

Exec=(cd /home/user; /var/lib/install/usr/bin/osso-xterm)

or to start a shell script which first cd-s into ~, then starts
osso-xterm. The latter works fine from the command line, but when
I try it from the application menu, nothing happens. This strikes me
as weird since following Israel Herraiz' examples in his blog one can
start shell scripts from the extra applications menu.

I have also tried putting cd /home/user into .profile and .ashrc (which
is in the ENV via .profile), but all this changes nothing.

It's a minor thing, but if someone has an idea, I'd appreciate it.



Stefan Boresch
Institute for Biomolecular Structural Chemistry
University of Vienna, Waehringerstr. 17       A-1090 Vienna, Austria
Phone: -43-1-427752715                        Fax:   -43-1-427752790

More information about the maemo-users mailing list