[maemo-users] [maemo-users] Hanging at NOKIA splash screen

From: skelso at nc.rr.com skelso at nc.rr.com
Date: Fri Jan 20 05:14:49 EET 2006
After a couple days of using my 770, I innocently turned it off and 
took out the battery to read the product ID.  Now it won't boot past 
the initial "NOKIA" splash screen.  I've seen others recover from 
similar situations by flashing, but I can't get to a point where the 
WinXP or Linux flasher will talk to my 770.  I'd really like to avoid 
doing a warranty return, because I know my local CompUSA doesn't have 
anything with which to replace it.  Any ideas what's wrong and how to 
fix it?

My experiments so far:

1) Pressing and holding the power button for a long time, with or 
without the power adapter attached -- nothing happens.

2) Pressing and holding the power button without the power adapter, 
then connecting the adapter while still holding the button -- the 
display immediately turns on and the "NOKIA" splash screen appears.  
The progress bar at the bottom of the screen never shows up.  If I 
release the power button, the backlight goes off after a few seconds, 
but in the right light I can see the display is still on and hung 
at "NOKIA".  It stays this way until I unplug power, at which point 
the display goes off.  If I continue holding the power button rather 
than releasing it, the backlight cycles at about 3s on/2s off.

3) Repeating the previous step with the USB cable attached to a WinXP 
PC -- The PC complains that an unknown USB device is attached, but the 
device isn't working correctly.  If I continue to hold the power 
button, the display and backlight flash about once a second until I 
release the button.  At the same time the PC cycles USB plug-unplug 
events until I pull the power adapter.  I'd successfully transferred 
files from that PC to the 770 via USB before the 770 started 

4) Repeating the previous two tests, but holding the home button 
before pressing the power button, makes no difference.  Likewise for 
the menu, escape, full-screen and plus/minus buttons.

5) Attaching the power adapter with the unit off does nothing.  The 
charging screen does not appear, and the display and backlight stay 

6) Attempting to flash from a WinXP system – the 770 never comes up.  
The PC cycles USB plug-unplug events, and eventually complains about 
an unknown USB device that isn't working correctly.  I know positively 
this 770 + USB cable + WinXP system combination worked before, because 
I'd used it to move files on and off the MMC.

7) Attempting to flash using the Linux flasher -- I first tried simply 
resetting the device using flasher:

"./flasher -R"

That didn't work, so I tried actually flashing it:

"./flasher -F Nokia_770_SE2005_3_2005_51-13.bin -f -R"

In both cases, I never got past "Suitable USB device not found, 
waiting".  However, I could hear the Linux system's disk churning a 
little about once a second when I was holding the 770's power button, 
making me think my Linux system is seeing the same USB plug-unplug 
cycling I got on my WinXP system.  I tried all of the USB ports on my 
Linux system, to make sure no internal hubs were getting in the way, 
and unfortunately the 770 behaved the same on every one.  I also tried 
both as a regular user and root.

This is the first time I've tried to flash my 770, although my saga 
began when I took out the battery to get the product ID so I could 
flash-up to the latest release.

I also tried flasher's "-c" cold-flash option, but it wanted a serial 
connection rather than USB.  Anyone know the pinout to the connector 
next to the battery?  I'm guessing a few of those pads are the needed 
serial port.

8) I considered maybe the flash code on the 770 is clever enough to 
check for a charged battery before allowing flashing to proceed.  My 
battery could be low by now.  But I measured it at 3.78V, so that 
pretty much rules that idea out.

More information about the maemo-users mailing list