[maemo-users] Flashing from powerpc and linux

From: digger vermont dv_mlist at verizon.net
Date: Sun Dec 9 17:12:41 EET 2007
Thanks for all the replies.

Steve, I think you were the only one though that took note that I have a
powerpc not an intel based computer. So no  flasher 2.0 or 3.0.

Since 0xFFFF can't yet flash a FIASCO image I ended up unpacking the
pieces for OS2007 and then separately installed them. That worked fine
except for the piece called "2nd". Don't know what 2nd does and so far I
haven't noticed a problem.

As far as the beta for OS2008 I get this error when trying to unpack it:

Dumping firmware pieces to disk.
Fiasco version:  2
Name: 1 RX-34_2008SE_1.2007.44-4_PR_MR0
   size:    1529984 bytes
   hash:    a84a
unexpected header at 0x1758f2, found 2e 19 01

At this point I image the mailing-list for 0xFFFF would be the place to


On Thu, 2007-12-06 at 18:47 -0500, Steve Yelvington wrote:
> digger vermont wrote:
> > It doesn't look like it can yet flash the image as a whole.  But it can
> > unpack the it into pieces as:
> >
> > 2nd, kernel, rootfs, xloader, initfs, secondary
> >   
> I don't know anything about the powerpc, but I flashed my N800 from an 
> Intel Macintosh with the early N810 image of OS2008 by using the cnet 
> blog's instructions. That included unpacking a whole mess of components 
> first.
> I later reflashed using the beta release of OS2008 for the N800, using 
> my daughter's Linux laptop. In that case I did a unitary upload without 
> first unpacking anything. Worked fine.

More information about the maemo-users mailing list