[maemo-users] N800 won't connect via WPA2...says "network does not support"

From: Mike Klein mklein at vxappliance.com
Date: Sun Oct 28 19:09:24 EET 2007
Thanks for help all.

I managed to unbrick my wrt54gl (tftp via orig. linksys firmware at
reboot of unit...whew!) and got onto v24RC4 (was on rc1). This and a
reboot after configuring for "WPA2Mixed/TKIP+AES" yields the following

8525 (WM5): Connect via WPA2/AES (at least it says so)
N800: Connect only via WPA (wpa2 still yields network msg)...not sure
whether tkip or aes.
ST5111 (WinXP): Now (After router reboot) uses WPA/AES and not
tkip...but still no wpa2.
    Tried Msoft and Athereos...only atheros had wpa2 option...but it
falls back to wpa.
Inspiron (WinXP): WPA-PSK/AES (not even option for wpa2)

So firmware upgrade only yielded ability to use AES whereas before all
clients were tkip. The router reboot after making settings changes may
have done this actually. dd-wrt seems to get a little confused when
you're in the ui going and forth between ssid hidden/visible and making
security changes.

I will start looking for dd-wrt bug/changelist (they don't bundle with
firmware downloads?!?) and am of belief now that (perhaps) WM5 is
"falling back" to WPA...although I do have it explicitly set to WPA2 and
not WPA. I wouldn't think fallback would NOT occur in this case as there
is specific selection for wpa2. Oddly enough my tablet pc (st5111) only
has WPA2/WPA option...wpa2 cannot be forced.

[side note]
dd-wrt is so flexible now. I could setup virtual ssid (all are hidden)
for my wife's old WEP-only laptop and further restrict access by macid.
I am even restricting by macid on wpa2 ssid as well. N800 is in these
lists although it's hostname doesn't show up in wifi list.

What was I thinking reflashing my primary AP first and not my backup
unit...that's what it's there for...doh!
[/side note]


Zoran Kolic wrote:
>> But this is bunk as my WM5 8525 connects via WPA2/AES! This totally 
>> blows me away...WM?!?
>> I notice my ST5111 atheros client has only "WPA/WPA2" option (no manual
>> select) and it seems to fallback to WPA/AES.
>> I am one release back from current firmware (the sdhc fix).
> I could confirm that wrt54gl supports wpa2 with aes encryption.
> Knowing that, you have to calmly find the way around. First, let
> the channel be 6 or 11. Then, go to just "g" mode emission. Let
> your mac address pass the firewall on the device. Set the appropriate
> password, at least 65 long. Set ssid to hidden. Then... Let wizard
> on n800 help you. Include hidden ssid as very important. On 770
> I made the connection from the very first attempt.
> Atheros chip is known as good for open source drivers. I have
> 5212 on freebsd box and it works just flowlessly. Linux drivers
> are similar, with no time outs or alike funs.
>                                      Zoran
> _______________________________________________
> maemo-users mailing list
> maemo-users at maemo.org
> https://lists.maemo.org/mailman/listinfo/maemo-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-users/attachments/20071028/c1ffe5b8/attachment.htm 
More information about the maemo-users mailing list