[maemo-users] MPlayer and Free42 for OS 2008

From: William Gordon Rutherdale will.rutherdale at utoronto.ca
Date: Wed Jan 2 02:26:56 EET 2008
I've gone to the web page but can't find where to submit a bug report.

I did, however, see what could be a related open bug:  962.

The file I created was a .avi, and I'm getting no audio.

Here is the command line I used to create it:

$ mencoder dvd://4 -o the_way_c.avi -srate 44100 -oac copy -ovc lavc 
-lavcopts acodec=mp3:abitrate=128
                   -af volnorm -ofps 29.970 -vf-add crop=640:384 -vf-add 
                   -vf-add unsharp=c4x4:0.3:l5x5:0.5 -ovc lavc
                   -ffourcc FMP4 -force-avi-aspect 1.66666666666667

I personally don't know what all those options mean, but I got them from 
playing with the script tablet-encode.  tablet-encode failed, but I 
adapted its parameters and ran the above command by hand.  For instance 
I put dvd://4 near the beginning myself.

Version of mplayer on the N800 with OS2007 is, I believe, 
1.0rc1-maemo.18.n800.  I don't know the best way to determine this 
straight off the tablet, but I know where I downloaded it from, which is 
the main downloads page under 2007 and Multimedia.

The generated video is 279301758 bytes in size.  I won't torture the 
whole list by attaching it.

To reiterate:  the symptoms are (i) no audio, and (ii) accelerated play 
rate.  I confirmed (ii) carefully by playing it side-by-side with 
mplayer on a regular linux pc.

I'll let you know if I figure out how to submit the bug on the garage 
web page, or better still maybe you can give me some tips.


BTW  I discovered from your URL a section that contains the download for 
the OS 2008 version of MPlayer.  I had sent more than one email asking 
for this information and got no responses.

Siarhei Siamashka wrote:
> On 1 January 2008, William Gordon Rutherdale wrote:
>> For the moment I've solved the problem by reverting to OS 2007 and
>> installing MPlayer and Free42 on there.
>> Along the way I dabbled with programming in scratchbox and got some
>> sample code running.
>> Regarding these two programs, I have found the following issues.
>> A)  MPlayer is not functioning properly.  I installed MPlayer on a
>> regular Linux PC.  I created a playable file from a DVD I own using
>> mencoder.  I confirmed that I can play the video on the regular PC using
>> mplayer.  However, when I run it on the N800 (using MPlayer installed on
>> OS 2007), I get these problems:
>>   i) No sound.  The Report function says "Audio: no sound".  Yet sound
>> comes out fine when I play it on the PC.
>>   ii) Seems to play in fast-forward fashion.
> You can go to https://garage.maemo.org/projects/mplayer and submit a
> bugreport. This bugreport should include exact mplayer version number, 
> audio codec that you tried to use (mencoder commandline should be enough),
> full mplayer output on your desktop PC (for the information about video and
> audio codec, resolution, bitrate, ...).

More information about the maemo-users mailing list