[maemo-users] MMC reported as read only

From: Kevin T. Neely ktneely at astroturfgarden.com
Date: Fri Jan 18 17:17:38 EET 2008
On Wed, Jan 09, 2008 at 08:16:52PM +0100, Frantisek Dufka wrote:

> Yes, extract via tar (tar zxvf kernel-sdhc*gz) and flash kernel image 
> either via Nokia linux flasher over USB (flasher-3.0 -f -k zImage -R) or 
> if you don't have linux PC you can flash directly from the device via my 
> kernel flasher script http://fanoush.wz.cz/maemo/#kernelflasher

I have continued my fight with the read-only MMC card.
Thanks to the above, I was able to flash the kernel with the MMC patches.  For some reaon, i couldn't get it done with the Linux flasher, but I had no problem using the above to do it directly on the device.  Thank you!

> If you have Kingston MMC 2GB card the 48MHz kernel should work and give 
> you best performance.

Part of my problem is that this might not be a real Kingston card.  RS-MMC is pretty much non-existent in stores, so I purchased a Hong Kong special on eBay.  On its own, it came back to a read/write state, but with only 1GB reporting.  Then, I managed to put it back to read-only by downloading some mp3s to the card.

I put it in my linux laptop, and reformatted the card.  I think my command was:

mkdosfs -c -F 32 /dev/[mmcdevice]

this worked just fine, but again was only 1GB, not 2.  I put it in my 770 (running the patched 4.2007.46-3) and it seemed to be working fine, but when gpodder had downloaded about 1/2 of 3 podcasts (average of 12MB each) gpodder quit because the card had gone read-only.  So, now I have the behavior pre and post kernel patch.

I am ready to blame the card, however, using a usb-based card reader, I was able to copy abotu 500MB of data to it last night, using both Linux and Windows.  So, the best I can tell, I have a decently-working 1GB rs-mmc card.

Until now, flash cards had "just worked" for me, so I am treading in unfamiliar water, and would appreciate any help or pointers you can give.  Also, is there a way to force the format to 2GB?  It might be interesting to try.

thank you in advance,

In Vino Veritas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: Digital signature
Url : http://lists.maemo.org/pipermail/maemo-users/attachments/20080118/57cd1b21/attachment.pgp 
More information about the maemo-users mailing list