[maemo-users] Memory card recognization issue in OS2008

From: Dr. Nicholas Shaw Doc at DocHarley.com
Date: Tue Jun 3 16:49:24 EEST 2008
Morning, Eero,

I tried reformatting in the device (a few times) - no go.  If I plug any of
the cards into a card reader, Windows can see the data and I was able to
copy the data to Windows prior to attempting reformat.  After attempting
reformat, Windows can still see the data.  BTW - I tried a 128MB card and it
worked, for a while.  I did a restore of bookmarks and GPE data and the N800
did an automatic restart.  After that - can't see the 128MB card either.
Fortunately I was able to copy the backup files to the 128 card and get the
restore going.

So I've tried three cards - 2 2GB cards and 1 128MB card.  The 128MB card
worked until a reboot now it doesn't.  Since the cards worked fine for the
backup I did before installing 2008 and the 128 worked after, I'm assuming
this is related to 2008.  I'll be submitting a bug report this morning.

When the cards are selected, the error is:

"Memory card is incorrectly formatted or corrupted.  Device can try to
restore files by repairing the card."  Selecting "Repair" has no effect.

Running dmesg produces:

	USB hub found
	1 port detected
	Standalone hub
	Individual port power switching
	No over-current protection
	Mmcblk1: error 1 transferring data
	End request: I/O error, dev mmcblk1, sector 133
	Printk: 181 messages suppressed.
	Buffer I/O error on device mmcblklp1, logical block 0
	End request: I/O error, dev mmcblk1, sector 134 (continues through
sector 164)
	Buffer I/O error on device mmcblklp1, logical block 1
	FAT: unable to read boot sector
	mmci-omap mmci-omap.1: command timeout
	mmcblk1: error 1 sending read/write command
	EXT3-fs: unable to read superblock
	Cx3110x: scanned 11 channels.
	mmci-omap mmci-omap.1: command timeout (CMD18)
	mmcblk1: error 1 sending read/write command

I've attached the complete dmesg file for your review.

Lastly, no, Windows cannot see the cards when they are in the device and the
device is connected via USB to the computer.  But if I remove the cards,
they are visible as is their data.

I've also noticed that xterm has an interesting bug - when you try to close
it with a control-D, it hangs and never goes away until you restart the
device.  I'll check to see if there's a bug report on that.  It's nice that
xterm is included; however, it's a bit different than the downloaded xterm I
used under 2007.

I sent the dmesg.output file to me using the 2008 mail client and the e-mail
went; however, like xterm, it didn't close so I have two programs that won't
close.  Time for a shutdown. :-)


-----Original Message-----
From: Eero Tamminen [mailto:eero.tamminen at nokia.com] 
Sent: Tuesday, June 03, 2008 01:58
To: ext Dr. Nicholas Shaw
Cc: 'Mark'; maemo-users at maemo.org
Subject: Re: Memory card recognization issue in OS2008


ext Dr. Nicholas Shaw wrote:
>>> Ok, new challenge.  I was able to copy the data from the two cards to my
>>> computer (had no problem at all) so don't know why the N800 now can't
>>> either of them.  I tried reformatting them and nada, zip, doesn't work.
>> Thanks, Mark.  I too have upgraded to a new release each time.  I bought
>> N800 the day it came out (1/8/2007) and each time I've upgraded the OS I
>> haven't had any problems with the cards.  Until this time (2GB each).  It
>> won't recognize either and I just did a backup yesterday and today and
>> cards are viewable by Windows.
>> So I've removed, reinserted, removed, reinserted, attempted to reformat
>> nothing has worked.

Did you reformat in Windows or in the device?

 > Mark, thanks for the recommendation (hard reset).  I tried it, didn't
 > work.  I keep getting a message that the cards (both) are corrupted or
 > unformatted.  At this point I'm not sure what to do.  This seems like
 > an OS2008 issue as they both worked yesterday and today when I backed
 > up and the cards are readable on my Windows Vista system.

If you plug in the USB cable, can Windows access the card through
the device? (i.e. is the issue in recognizing the card itself, or
just the partition contents)

If you run "dmesg" (e.g. from device X terminal) after re-inserting
the card, what it says?

	- Eero

 >> You ever have one of those days when you want to take
 >> all your gizmos outside and blast them with a shotgun? :-)

Last weekend, with our DVD player (didn't eject the disk before I
dismantled and closed again the case, then it mysteriously started
working again without doing anything else)...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dmesg.output
Type: application/octet-stream
Size: 15550 bytes
Desc: not available
Url : http://lists.maemo.org/pipermail/maemo-users/attachments/20080603/b0d8504e/attachment.obj 
More information about the maemo-users mailing list