[maemo-users] Memory card recognization issue in OS2008

From: Mark wolfmane at gmail.com
Date: Tue Jun 3 18:31:55 EEST 2008
On Tue, Jun 3, 2008 at 7:49 AM, Dr. Nicholas Shaw <Doc at docharley.com> wrote:
> Morning, Eero,
> I tried reformatting in the device (a few times) - no go.  If I plug any of
> the cards into a card reader, Windows can see the data and I was able to
> copy the data to Windows prior to attempting reformat.  After attempting
> reformat, Windows can still see the data.  BTW - I tried a 128MB card and it
> worked, for a while.  I did a restore of bookmarks and GPE data and the N800
> did an automatic restart.  After that - can't see the 128MB card either.
> Fortunately I was able to copy the backup files to the 128 card and get the
> restore going.
> So I've tried three cards - 2 2GB cards and 1 128MB card.  The 128MB card
> worked until a reboot now it doesn't.  Since the cards worked fine for the
> backup I did before installing 2008 and the 128 worked after, I'm assuming
> this is related to 2008.  I'll be submitting a bug report this morning.
> When the cards are selected, the error is:
> "Memory card is incorrectly formatted or corrupted.  Device can try to
> restore files by repairing the card."  Selecting "Repair" has no effect.
> Running dmesg produces:
>        USB hub found
>        1 port detected
>        Standalone hub
>        Individual port power switching
>        No over-current protection
> -----------------*****------------------
>        Mmcblk1: error 1 transferring data
>        End request: I/O error, dev mmcblk1, sector 133
>        Printk: 181 messages suppressed.
>        Buffer I/O error on device mmcblklp1, logical block 0
>        End request: I/O error, dev mmcblk1, sector 134 (continues through
> sector 164)
>        Buffer I/O error on device mmcblklp1, logical block 1
>        FAT: unable to read boot sector
>        mmci-omap mmci-omap.1: command timeout
>        mmcblk1: error 1 sending read/write command
>        EXT3-fs: unable to read superblock
>        Cx3110x: scanned 11 channels.
>        mmci-omap mmci-omap.1: command timeout (CMD18)
>        mmcblk1: error 1 sending read/write command
>        ...
> I've attached the complete dmesg file for your review.
> Lastly, no, Windows cannot see the cards when they are in the device and the
> device is connected via USB to the computer.  But if I remove the cards,
> they are visible as is their data.
> I've also noticed that xterm has an interesting bug - when you try to close
> it with a control-D, it hangs and never goes away until you restart the
> device.  I'll check to see if there's a bug report on that.  It's nice that
> xterm is included; however, it's a bit different than the downloaded xterm I
> used under 2007.
> I sent the dmesg.output file to me using the 2008 mail client and the e-mail
> went; however, like xterm, it didn't close so I have two programs that won't
> close.  Time for a shutdown. :-)
> Thanks,
> Nick.

I would try reflashing the OS, in case your last flash got corrupted.
If that doesn't work, it's not sounding promising for the hardware.

You have made sure that the little write-protect switches on the cards
are in the unlocked position, right? Some readers ignore those
switches, though, and I had one reader that malfunctioned and always
reported the card was write-protected when it wasn't. I thought the
card itself was toast, but I got a new reader and the card worked fine
thereafter. I hope the same thing hasn't happened to your Nokia.


More information about the maemo-users mailing list