[maemo-users] Claws Mail won't start

From: lakestevensdental lakestevensdental at verizon.net
Date: Wed Jan 21 01:45:07 EET 2009
Rick Bilonick wrote:
> On Sat, 2009-01-17 at 04:37 -0500, Peter Bart wrote:
>> On Sat, 17 Jan 2009 01:55:19 -0500
>> Rick Bilonick <rab at nauticom.net> wrote:
>> <snip>
>>>> If you have the mailboxes on one of the memory cards check to see
>>>> if the card is read only. I had that issue and discovered a RS-MMC
>>>> had spontaneously protected itself. I reformated the card, verified
>>>> that was the problem and replaced the card. I seem to remember a
>>>> bug about that but don't quote me. I just got rid of my old cards.
>>>> Best Regards, 
>>> I'm running the N810 from an 8gb external memory card. I uninstalled
>>> claws and all components and re-installed but it still refuses to run.
>>> Everything else runs fine. I tried running claws-mail from an X shell.
>>> It does not report any errors. But the gui never appears. It used to
>>> work.
>> I'm afraid this is way past me. If I understand you correctly you are
>> booting from the memory card? Claws normaly installs itself
>> to /usr/bin IIRC and puts its config into /home/user/.claws. Where
>> yours are  don't know. I might check for multiple files where there
>> should be just one? When you say there are no errors when starting
>> Claws from xterm, does anything output or do you simply get a command
>> prompt? Good luck.  
> Yes, you clone the image on the flash memory to the external card and
> install a boot menu. I don't pretend to understand all the details (the
> installation process is all automatic thanks to wonderfully talented
> programmers and hackers) but for all practical purposes everything works
> just like it was booting from flash memory - the file structure is the
> same. Claws worked just fine booting from the external card. It's just
> in the last few weeks that it stopped working.  I was just wondering if
> anyone else was having this problem. Everything else (and I've
> downloaded a lot given I have an 8gb card) has worked fine and continues
> to work.
> Rick B.
I had a somewhat similar sounding Claws problem a couple months ago.  
Claws would boot, but couldn't do anything else.  I had the mail stored 
on the internal memory (4G card), not in the core internal memory (or 
whatever you want to call it).  I reinstalled Claws -- that didn't help. 

Then somewhere during the process below, everything cleared up.  I'm not 
sure exactly when.  

I updated to the latest flash of the OS in December.  During this 
process, I swapped my 4G card for the external 8G card (making it the 
internal card).  

During (or before flashing), I also had a few issues with goofed up 
catalogs and repositories that required me to delete catalogs in app 
manager and reinstall apps to get the proper catalogs and repositories 
for app manager to do its thing.  Just because you reinstall with app 
manager, doesn't mean everything is necessarily properly updated if app 
manager is continuing to use bogus, outdated or abandoned catalogues and 
repos.  As I understand it, at the end of the year there started a well 
intented attempt (somewhat disorganized in implementation) to migrate 
stuff to a centralized depot of some sort to prevent the hassles of 
stuff moving around in cyberspace confusing app manager.  This migration 
messed things up for those who were left pointing at the older 
repositories and catalogs in app manager.   App manager won't 
necessarily report these things to you.  As I recall, it just freezes up 
a few minutes, then says everything is updated, when it's not.  I'm not 
sure Claws was part of this, it could be, or not...  It's just one of 
those dynamics you come to expect in 'free' linux support... 

  At this point, I can't recall if I reinstalled Claws after the flash 
and restore, or if it worked after the restore.  I kind of think it took 
reinstalling after the restore and after I deleted most every catalog 
from app manager.   I also don't recall if I was able to salvage the old 
email files and had to reconstruct everything (which I've had to do a 
couple times).  I did reformat both cards at some point in the process.  
I was also careful to create the same folder and file locations on the 
new internal card for the claws folders.  Also, as precaution, both 
cards had backup copies on a desktop harddrive.  It like what else are 
you supposed to do with a terabyte of HD space?  

  As a side note, my tablet email settings are always to leave messages 
on the server.  I consider my desktop to be the backup/storage unit.  
When it downloads email, it takes them off the servers.  I typically 
have something like 400M or more of BS archived on my desktop harddrives 
at most any point in time, and I delete a lot all the time from the 

   In other words, I don't consider copies of email on my tablet as 
critical. I usually blow thru and delete emails them by the hundreds on 
the tablet on a daily basis...   IMHO, you are asking for trouble if you 
store too much critical stuff on tablet memory, particularly emails, 
which can quickly balloon in size...    

  Basically stuff happens, then you've got theft, and owner stupidity 
(leaving it somewhere, washing them).  Don't look at tablets as a secure 
long term storage device...

Always, Fred Chittenden

More information about the maemo-users mailing list