[maemo-users] Some buttons not working properly on N800

From: João Marcelo jmarcelo.alencar at gmail.com
Date: Wed Sep 9 01:26:27 EEST 2009
the system does performs slightly better after the crawler patch. but
the problem persists, cannot unlock the keys. the other buttons are
more responsive while using another applications.

but not i configured the ssh-server and i'm checking the dmesg while i
click the button. i get a lot of these:

EAC mode: play disabled, rec disabled

is it somehow related or a completely different beast?

On Tue, Sep 8, 2009 at 6:57 PM, Mark<wolfmane at gmail.com> wrote:
> On Tue, Sep 8, 2009 at 3:30 PM, João Marcelo<jmarcelo.alencar at gmail.com> wrote:
>> On Tue, Sep 8, 2009 at 6:10 PM, Mark<wolfmane at gmail.com> wrote:
>>> On Sun, Sep 6, 2009 at 6:39 PM, João Marcelo<jmarcelo.alencar at gmail.com> wrote:
>>>> Helo Community,
>>>> I've just bought a brand new nokia n800 tablet. It comes loaded with a
>>>> old version of Maemo so I followed the instructions on
>>>> http://wiki.maemo.org/Updating_the_tablet_firmware . I updated to the
>>>> latest version, RX-34_DIABLO_5.2008.43-7_PR_COMBINED_MR0_ARM.bin using
>>>> flasher-3.0.
>>>> Everything worked just fine, the device rebooted. The problem happens
>>>> when I single click the power button, the device mode menu appears and
>>>> choose 'Lock touch screen and keys'. The screen is locked and I just
>>>> can't unlock. When I click the power button again, a message asking me
>>>> to press the central button appears. I click it, but the device
>>>> doesn't unlock. The button seems to work with other applications, but
>>>> it isn't something reliable, sometimes it doesn't work. The same can
>>>> be said about all the other buttons, including the directional
>>>> buttons, the return, menu and home buttons.
>>>> Is it a hardware problem or by any chance is it related with software?
>>> I suspect that there is a software issue. I don't usually have any
>>> trouble unlocking the touch screen and keys, but I have a devil of a
>>> time unlocking the device with the numeric code if I shut it down
>>> while locked. I think that may be related to the piece of crap
>>> metalayer-crawler hogging 100% of the system resources for several
>>> minutes on bootup. Whose brilliant idea was it to design that process
>>> to run on startup with top priority, anyway? It should only run with a
>>> very low priority and allow other processes to run first.
>> suppose this is the reason. is there a way to edit the init scripts
>> and change this process priority? this is a good explanation and also
>> explains other strange behaviors. i'm starting to consider the idea
>> that i'll have to learn with this.....
> https://bugs.maemo.org/show_bug.cgi?id=978
> I haven't tried the solution yet myself - the details are pretty sketchy.
> Mark
> _______________________________________________
> maemo-users mailing list
> maemo-users at maemo.org
> https://lists.maemo.org/mailman/listinfo/maemo-users

João Marcelo Uchôa de Alencar
Computer Science BSc.
Linux User 398939
More information about the maemo-users mailing list