[maemo-users] Troubles with chrooted Debian

From: Pavel Řezníček cigydd at gmail.com
Date: Mon Jan 9 00:41:43 EET 2012
Dne 5.1.2012 01:41, Paul Hartman napsal(a):
> On 1/4/2012 4:32 PM, Pavel Řezníček wrote:
>> My current one and only card is TDK 8GB Life on Record, class unknown
>> for now.
>> I’m not sure if I can buy one from Amazon directly because I’m neither
>> an US nor UK resident.
>> Still thanks for your recommendation, it’s very valuable for me.
> Replace Amazon with "trusted store" in your country who does not sell
> counterfeit products. (So, do not buy SD card from eBay, DealExtreme, etc.)
I’ve just purchased a SanDisk 16GB Micro SD card but it’s not class 6 as 
stated before but class 4, actually. I expect it to arrive on Monday 
January 9th, it means tomorrow.
>> I’d though appreciate if you send me the precompiled kernel module
>> (along with some instructions or web resources how to install it).
> It is attached inside a ZIP file. This module is only for use with stock
> kernel, not power kernel!
> If your card was affected by this bug, hopefully using this module will
> now allow your card to work with no more corruption (after reformat).

Dear Paul, I tried your module. Everything went OK! … until I tried to 
rsync everything from the card to an image file stored in ~/MyDocs. I 
tried it twice and in both cases an unwanted reboot and filesystem 
corruption occured, inspite that I ran rsync with the nice -n 19 prefix.
I called rsync from a bash script with "sudo nice -n 19 <that_script>" 
actually. I suppose that every child process inherits the niceness of 

But I also tried to perform a sudo apt-get update; sudo apt-get 
dist-upgrade before. That worked pretty good except that some corruption 
was already present on the filesystem (after an fsck repair) that didn’t 
allow the upgrade to finish. Next time I’ll try on a fresh Debian partition.

So it appears that:
– the dist-upgrade seems to work :-) thank to the fixed kernel module 
from you, Paul;
– as the image file became involved (during an rsync backup process), 
the reboot and corruption occured twice already :-( ; the image file and 
the partition on the microSD card both became corrupt;
– maybe I should

   1. forget about the image file for now,
   2. concentrate myself on work with the microSD card partition,
   3. use the image file as a read-only rescue backup solution and
   4. back the system on the card up to another place than to the
      mounted image file on my device, i. e. to my PC, or use dd instead
      of rsync.

Anyway, other ideas to figure out what’s going on here? Why is my N900 
rebooting unexpectedly even when I am very nice to it?

Thank you, Paul and Michael, for your suggestions! I hope we’ll finally 
find the way out of this weird story ;-)


function Podpis(): String;
   Jméno('Pavel Řezníček');
   Bydliště('Borová 18', '312 00', 'Plzeň');
   Pracoviště('Korandův sbor', 'Anglické nábřeží 13', '301 00', 'Plzeň');
   Result := 'vývojář a správce sítě';

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.maemo.org/pipermail/maemo-users/attachments/20120108/0a7d03e8/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cigydd.vcf
Type: text/x-vcard
Size: 598 bytes
Desc: not available
URL: <http://lists.maemo.org/pipermail/maemo-users/attachments/20120108/0a7d03e8/attachment.vcf>
More information about the maemo-users mailing list