[maemo-users] Bluetooth mouse.

From: David Hagood david.hagood at gmail.com
Date: Wed Mar 7 04:09:24 EET 2007
I cannot speak for Bluetooth mice, but I tried a USB mouse via a powered 
hub on my N770 running the latest production OS2006.

In fact, on the hub I had:

A USB to PS/2 keyboard+mouse adapter, with both mouse and keyboard in place.
A USB to RS-232 adapter with a GPS on it (through a serial monitor box 
with LEDs on the various data lines)
A USB mouse (in addition to the PS/2 mouse)

I had previously modified the /etc/init.d/x-server.sh file to tell the X 
server to look at /dev/input/mice

Here were my results:

Mouse: Not working. dmesg shows the mouse as detected, the mice show up 
in /sys/bus/usb/devices, but lsof shows that Xomap did NOT open the  
/dev/input/mice file. (checking the /proc/<pid of Xomap>/cmdline shows 
that the command line was indeed modified). cat'ing /dev/input/mice did 
not yield any data when the mouse was moved.

Keyboard - worked. Having the Bluetooth keyboard plugin was helpful as 
it turned off the virtual keyboard when the external keyboard was activated.

GPS: Didn't work. I was unable to get MaemoMapper to indicate GPS lock, 
after having set the GPS device to /dev/ttyUSB0. I had modified the 
permissions on the serial devices to be world readable. and I was able 
to verify that when Maemomapper opened the device RTS was asserted. I 
was able to verify that the GPS was sending data, but the data was not 
received by Maemomapper. cat'ing the serial device yielded no data. 
dmesg showed several input overrun messages from the serial device.

More information about the maemo-users mailing list