[maemo-users] N810 and Huawei E220 USB HSDPA modem

From: Tommy Persson tpe at ida.liu.se
Date: Sat Feb 16 01:31:45 EET 2008
Tommy Persson <tpe at ida.liu.se> writes:

> I am trying to connect a Huawei E220 modem (HSDPA) to my N810. It
> worked directly on my debian unstable machine. I have tried to compile
> some additional modules like usbserial and use them but it does not
> seem to work. Does anybody know if it is possible to get this to work
> just compiling som extra modules or do I have to build a new image?

I can report that by connecting the modem to a powered hub I got it to
work by just insmod usbserial. I managed to create a ppp connection
also so it works in principle. Now i just have to figure out how to
configure it so it become convenient to use.

But the power thing was irritating. The modem has two USB connections
and one is only for power. So I connected an USB-battery that can give
700 mA to the power connection and still the N810 said that there was
not enough power and failed to start things properly. I wonder if this
just is a problem with power requirement detection. Can you disable
this detection? I suspect that the modem does not see that it is
connected to a battery and therefore reports that it needs a lot of

/Tommy Persson

More information about the maemo-users mailing list