[maemo-users] N810 and Huawei E220 USB HSDPA modem

From: John Holmblad jholmblad at acadiasecurenets.com
Date: Sat Feb 16 04:35:00 EET 2008

I am waiting for the arrival of a  product similar to the one you have 
except with EVDO + self (battery) powering + bluetooth support. In 
effect, what I want is a mobile phone but "hold the voice, keypad, 
etc.).  Maybe Nokia will come up with one of these do-dads since they 
are into the "no-wires" paradigm these days.

Best Regards,


John Holmblad


Acadia Secure Networks, LLC

* *

*Serving the entrepreneurial enterprise, emerging network service 
provider, and SmartDigital^TM home markets*

* *

*GSEC Gold,  GCWN Gold,  GAWN,  GGSC-0100,  NSA-IAM,  NSA-IEM***

*Microsoft Small Business Specialist | Speakeasy Certified VOIP Partner 
| Linksys Authorized LVS Partner | Qualys Certified Qualysguard Specialist*

* *

(M) 703 407 2278

(F)  703 620 5388


(W) www.acadiasecure.com


primary email address:  jholmblad at acadiasecure.com 
<mailto:jholmblad at acadiasecure.com>

backup email address:  jholmblad at verizon.net <mailto:jholmblad at verizon.net>

Tommy Persson wrote:
> Tommy Persson <tpe at ida.liu.se> writes:
>> I am trying to connect a Huawei E220 modem (HSDPA) to my N810. It
>> worked directly on my debian unstable machine. I have tried to compile
>> some additional modules like usbserial and use them but it does not
>> seem to work. Does anybody know if it is possible to get this to work
>> just compiling som extra modules or do I have to build a new image?
> I can report that by connecting the modem to a powered hub I got it to
> work by just insmod usbserial. I managed to create a ppp connection
> also so it works in principle. Now i just have to figure out how to
> configure it so it become convenient to use.
> But the power thing was irritating. The modem has two USB connections
> and one is only for power. So I connected an USB-battery that can give
> 700 mA to the power connection and still the N810 said that there was
> not enough power and failed to start things properly. I wonder if this
> just is a problem with power requirement detection. Can you disable
> this detection? I suspect that the modem does not see that it is
> connected to a battery and therefore reports that it needs a lot of
> power.

More information about the maemo-users mailing list