[maemo-users] Write access for MMC

From: James Knott james.knott at rogers.com
Date: Tue Oct 14 22:31:34 EEST 2008
Shivkumar Chandrasekaran wrote:
> On Tue, 2008-10-14 at 21:02 +0200, Damien Challet wrote:
>> On Tuesday 14 October 2008 20.48:40 James Knott wrote:
>>> Shivkumar Chandrasekaran wrote:
>>>> Hi,
>>>> I have a 770 with OS2007 Hacker's edition with a 1GB removable card.
>>>> Everything worked fine until yesterday when I suddenly lost write-access
>>>> to the card. So I can no longer do backups or write or remove files from
>>>> the File Manager. I tried connecting it to my Linux machine using the
>>>> USB cable, but the Linux machine also insists that the file system on
>>>> the USB drive is read-only (so I could not delete files for example from
>>>> linux terminal, even with super-user permission).
>>>> Can anyone give me some advice so that I can re-acquire write access?
>> the file system card can be corrupted and needs an fsck.
> Any idea how I can do that? When I chose "Memory card -> mmc2 ->
> Format ..." from File Manager it tells me that the memory card is in
> use. I tried booting up without the memory card and then inserted it
> later to no effect.

Do you have a separate card reader?  If so, plug it in there to work on 
it.  Or if you connect it via USB cable to another computer, is it then 
available?  Either way, copy all the files off it, before doing anything 
that writes to it.

Use OpenOffice.org <http://www.openoffice.org>

More information about the maemo-users mailing list